summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2020-09-11 23:13:25 +0900
committerAkinori Hattori <hattya@gentoo.org>2020-09-11 23:13:25 +0900
commitcac522c6118425ae212d6a83809c9761a300d39b (patch)
treeab8eab9328b0094ed62982b452f5dea5536d00b4 /app-i18n
parentapp-i18n/ibus-table: new upstream release (diff)
downloadgentoo-cac522c6118425ae212d6a83809c9761a300d39b.tar.gz
gentoo-cac522c6118425ae212d6a83809c9761a300d39b.tar.bz2
gentoo-cac522c6118425ae212d6a83809c9761a300d39b.zip
app-i18n/ibus-typing-booster: new upstream release
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.9.7.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index 921a4bd2efce..b57d32cae2dc 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,2 +1,3 @@
DIST ibus-typing-booster-2.9.5.tar.gz 8236281 BLAKE2B 749890cc3477db890603c9a700bff1a097fd2cd09d01477f319658c65c73688903171e49a0284176ce396d83587ef23a067a0aabe81c57bf70479050a15e8c80 SHA512 58db7d7e687512d8c436b23c28e1c614d56f486de13153f5ddfddecf32595f6de8c8289273b288c1df857dac5577df3eea48ca900b709a13b9c91b2e0ec21286
DIST ibus-typing-booster-2.9.6.tar.gz 8238571 BLAKE2B f0d64d71c778bc47427ae7b87a23d53f77a537765113334cada73312452cfc0c66f8a321ff17f7722da6554230347253ac2bd0e311b4c5a8831dc17f34e8ef72 SHA512 d3038b744ba5049fed8cf4ba9d455502ef3061f35604d135ffb15604bbac78be1b4ba4232528daf87cb750772309cc9745d7ebc31ced2fc989395e0c62701eb4
+DIST ibus-typing-booster-2.9.7.tar.gz 8833452 BLAKE2B 4c4f33bcff2fa9e20afeccf242bec1a6e11fca0b5cb515b2c2dce7ef2401c092a7197a6637e2ca72d4c1bacd694860c07ae645a313e41cd879d6bde8c1736d12 SHA512 984beacdd6b853e074127372a912442ba1dbc536ecf194a34d03025277b9d6277e967e63a9bdcd1620f5094965a191297ccae9adbff2d54d1cd474437a1ec16b
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.9.7.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.9.7.ebuild
new file mode 100644
index 000000000000..ed1abe745449
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.9.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_MULTI_USEDEP}]
+ dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyenchant[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyxdg[${PYTHON_MULTI_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}