summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-10-19 22:40:05 +0200
committerMike Gilbert <floppym@gentoo.org>2017-10-23 13:24:40 -0400
commitdfac9a0ed3704dfd103110c3f8718d870caecde1 (patch)
treef0bf045745227a337f37556499be0f9d8f0259db /app-i18n
parentapp-i18n/fcitx-anthy: Version bump (0.2.3). (diff)
downloadgentoo-dfac9a0ed3704dfd103110c3f8718d870caecde1.tar.gz
gentoo-dfac9a0ed3704dfd103110c3f8718d870caecde1.tar.bz2
gentoo-dfac9a0ed3704dfd103110c3f8718d870caecde1.zip
app-i18n/fcitx-anthy: Add live ebuild.
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/fcitx-anthy/fcitx-anthy-4.9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-i18n/fcitx-anthy/fcitx-anthy-4.9999.ebuild b/app-i18n/fcitx-anthy/fcitx-anthy-4.9999.ebuild
new file mode 100644
index 000000000000..c5fba16429b0
--- /dev/null
+++ b/app-i18n/fcitx-anthy/fcitx-anthy-4.9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-anthy"
+fi
+
+DESCRIPTION="Japanese Anthy input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-anthy"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4[X,xml]
+ app-i18n/anthy:=
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=(AUTHORS)
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}