summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-28 23:47:37 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-28 23:49:58 +0100
commite91feac5e44d47f503542a10a44779c31f0b2071 (patch)
tree4c543f36c90163241cd42f1fe41a8d0ab8fac756 /app-i18n
parentapp-i18n/pology: EAPI-7, use kde.org, cmake.eclass, disable epydoc (diff)
downloadgentoo-e91feac5e44d47f503542a10a44779c31f0b2071.tar.gz
gentoo-e91feac5e44d47f503542a10a44779c31f0b2071.tar.bz2
gentoo-e91feac5e44d47f503542a10a44779c31f0b2071.zip
app-i18n/pology: Sync with 9999, disable epydoc
Closes: https://bugs.gentoo.org/707036 Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/pology/pology-0.12-r1.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/app-i18n/pology/pology-0.12-r1.ebuild b/app-i18n/pology/pology-0.12-r1.ebuild
new file mode 100644
index 000000000000..da1015d3f26b
--- /dev/null
+++ b/app-i18n/pology/pology-0.12-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+inherit bash-completion-r1 cmake kde.org python-single-r1
+
+DESCRIPTION="A framework for custom processing of PO files"
+HOMEPAGE="http://pology.nedohodnik.net"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="http://pology.nedohodnik.net/release/${P}.tar.bz2"
+ KEYWORDS="amd64 x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.5
+"
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+
+# Magic on python parsing makes it impossible to make it parallel safe
+MAKEOPTS+=" -j1"
+
+src_prepare() {
+ cmake_src_prepare
+ sed -e "/DOC_INSTALL_DIR/s/^/#DONT/" -i CMakeLists.txt || die
+ python_fix_shebang .
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DDOC_INSTALL_DIR="${EPREFIX}"/usr/share/doc/${PF}
+ -DCMAKE_DISABLE_FIND_PACKAGE_Epydoc=ON
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ python_optimize
+
+ dosym ../../../pology/syntax/kate/synder.xml /usr/share/apps/katepart/syntax/synder.xml
+
+ newbashcomp "${ED}"/usr/share/pology/completion/bash/pology posieve
+ bashcomp_alias {posieve,poediff}{,.py}
+
+ elog "You should also consider following packages to install:"
+ elog " app-text/aspell"
+ elog " app-text/hunspell"
+ elog " dev-vcs/git"
+ elog " dev-vcs/subversion"
+ elog " sci-misc/apertium"
+}