summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Siebeck <gentoo.2019@r123.de>2020-09-04 13:47:52 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-10-02 09:45:18 +0300
commite9836f36e93997cb8a64e239a52e1230ab69c2e0 (patch)
tree3041ee8b31a3747727d560ee56f7d37bea25d8f4 /app-i18n
parentpackage.mask: adonthell and wastesedge ported to python-3 (diff)
downloadgentoo-e9836f36e93997cb8a64e239a52e1230ab69c2e0.tar.gz
gentoo-e9836f36e93997cb8a64e239a52e1230ab69c2e0.tar.bz2
gentoo-e9836f36e93997cb8a64e239a52e1230ab69c2e0.zip
app-i18n/transifex-client: add version 0.13.12
Signed-off-by: Robert Siebeck <gentoo.2019@r123.de> Closes: https://github.com/gentoo/gentoo/pull/17410 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/transifex-client/Manifest1
-rw-r--r--app-i18n/transifex-client/transifex-client-0.13.12.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-i18n/transifex-client/Manifest b/app-i18n/transifex-client/Manifest
index 7db2792949cc..0df52ab374fc 100644
--- a/app-i18n/transifex-client/Manifest
+++ b/app-i18n/transifex-client/Manifest
@@ -1 +1,2 @@
+DIST transifex-client-0.13.12.tar.gz 211369 BLAKE2B e536e2d1c33c9a64326cac9bab2a5d162fc554185127b2e8d3fc77e81cb4f19b8c2b66b5bd4502cf3129bbf1f0aa2c6649552392831b3d2b6ed322170de31952 SHA512 e4a5c78f3cdf589ad186a09b8ada09e06a725499234c03a037f8a8fb33447fb25edaf921a395ce8cb31c11c08a21dbb1b7b35cf54276995d255ddb2382e549c9
DIST transifex-client-0.13.9.tar.gz 197283 BLAKE2B 9fd6f63a54d09f190f7dd6701e4994e4fd67e23cf630dcb49641a3c7356e55f1146be7c2a590fb09a52cccfa99e709c48fffd7df416d1d4c10231c4f42919380 SHA512 3dc4a1e713a797ce1ea626c9e85dd353fec3034ba21ab04bc89e5b927e0298b4f6560a793eec50d1a99c7ab340462c33d18c1e159697c476001be868cb7f87fa
diff --git a/app-i18n/transifex-client/transifex-client-0.13.12.ebuild b/app-i18n/transifex-client/transifex-client-0.13.12.ebuild
new file mode 100644
index 000000000000..9a36eedf7f4e
--- /dev/null
+++ b/app-i18n/transifex-client/transifex-client-0.13.12.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A command line interface for Transifex"
+HOMEPAGE="https://pypi.org/project/transifex-client/ https://www.transifex.net/"
+SRC_URI="mirror://pypi/t/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+RDEPEND="dev-python/GitPython[${PYTHON_USEDEP}]
+ <dev-python/python-slugify-5.0.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ <dev-python/six-2.0.0[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+src_prepare() {
+ eapply_user
+ sed -i -e 's:test_fetch_timestamp_from_git_tree:_&:' \
+ tests/test_utils.py || die
+}