summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2017-06-18 11:17:04 +0200
committerPacho Ramos <pacho@gentoo.org>2017-06-18 11:17:28 +0200
commitfca6415a9829db5fa82e87c5f3cf1d2d4e4cb69b (patch)
treeac579e5127e7413fb617820e54e8d8a142944699 /app-laptop/batti/batti-0.3.8-r4.ebuild
parentmedia-plugins/gst-plugins-meta: bump to 1.10.5 (diff)
downloadgentoo-fca6415a9829db5fa82e87c5f3cf1d2d4e4cb69b.tar.gz
gentoo-fca6415a9829db5fa82e87c5f3cf1d2d4e4cb69b.tar.bz2
gentoo-fca6415a9829db5fa82e87c5f3cf1d2d4e4cb69b.zip
app-laptop/batti: Support current upower version (#600914 by idl0r), hicolor-icon-theme provides the enough icons for this.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'app-laptop/batti/batti-0.3.8-r4.ebuild')
-rw-r--r--app-laptop/batti/batti-0.3.8-r4.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-laptop/batti/batti-0.3.8-r4.ebuild b/app-laptop/batti/batti-0.3.8-r4.ebuild
new file mode 100644
index 000000000000..a0f42c02fb87
--- /dev/null
+++ b/app-laptop/batti/batti-0.3.8-r4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 gnome2-utils
+
+DESCRIPTION="A upower based battery monitor for the system tray, similar to batterymon"
+HOMEPAGE="https://code.google.com/p/batti-gtk/"
+SRC_URI="https://batti-gtk.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+RDEPEND="
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ || ( sys-power/upower sys-power/upower-pm-utils )
+ x11-themes/hicolor-icon-theme
+ libnotify? ( x11-libs/libnotify )
+"
+DEPEND=""
+
+src_prepare() {
+ default
+ if has_version ">=sys-power/upower-0.99"; then
+ eapply "${FILESDIR}/${P}-upower-0.99.patch"
+ eapply "${FILESDIR}/${P}-upower-capital.patch"
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}