summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-05-29 08:23:27 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2022-05-29 08:23:37 +0200
commitda9a0d9329790568aece0d42f91f27b185ef921b (patch)
tree2a2178ad669cacce32833870d8bf5c8ba1e495d8 /app-laptop/rogauracore
parentprofiles/package.mask: mask regexp_parser slots for removal (diff)
downloadgentoo-da9a0d9329790568aece0d42f91f27b185ef921b.tar.gz
gentoo-da9a0d9329790568aece0d42f91f27b185ef921b.tar.bz2
gentoo-da9a0d9329790568aece0d42f91f27b185ef921b.zip
app-laptop/rogauracore: bump to 1.6, eapi8, inherited udev, updated live
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'app-laptop/rogauracore')
-rw-r--r--app-laptop/rogauracore/Manifest1
-rw-r--r--app-laptop/rogauracore/rogauracore-1.6.ebuild39
-rw-r--r--app-laptop/rogauracore/rogauracore-9999.ebuild10
3 files changed, 47 insertions, 3 deletions
diff --git a/app-laptop/rogauracore/Manifest b/app-laptop/rogauracore/Manifest
index 0b12c9002c2a..a6de841fae4d 100644
--- a/app-laptop/rogauracore/Manifest
+++ b/app-laptop/rogauracore/Manifest
@@ -1,2 +1,3 @@
DIST rogauracore-1.4.tar.gz 10305 BLAKE2B 27e94af50d318a3ce87f87236367aea72ee8daa2b0db896daeaa19bb75b6266faca2aca127d6444b759e6b7029c9f2eee1076ca4a197d70c4dfc2c611f5419ed SHA512 5179bfdfa8eeca5d7ac3ec87e4226429fa8d7987dc2d824a73a8a99142ceaf6fbda16f9844a62ecc8c629c44e334f940dff318bb3e2a3057c0bd1620d0f92c36
DIST rogauracore-1.5.tar.gz 10442 BLAKE2B 1720ebd4808e814f0af77ed55027accd37645a0375eb3d29a814fe50624b8fadd2cde274cf0f33b87b83dd3be60d06513054df04f4e00a4e0168f5ff42d1ef50 SHA512 7ea47b9fa411ebe1176d9fbba3a814dbe67697d23b991547674f0ce2fd9b6536fce806e9dcf005f41de47f70bca543a7d8e77fa1fb35ed239ebc59a48746e1fc
+DIST rogauracore-1.6.tar.gz 10617 BLAKE2B 5472346f94326fd94bb51b1b8561a1257c07ed82e95f1e7ff3cd5be162ed2ef2ade6035d78ef2e1d8213ddc94c84975d86180042e0cbb97ab60d7de36c14a37f SHA512 93446614ebfb56a4bc63b14fcbd65632e35f8ec3eec463db311fd58bf525a60982dc6c5debc94841bb5c0dcc052608f5fb288065a0765c8eda94c40830b367d3
diff --git a/app-laptop/rogauracore/rogauracore-1.6.ebuild b/app-laptop/rogauracore/rogauracore-1.6.ebuild
new file mode 100644
index 000000000000..5c7ce4a941bd
--- /dev/null
+++ b/app-laptop/rogauracore/rogauracore-1.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools udev
+
+if [[ ${PV} = "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/wroberts/rogauracore.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/wroberts/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="RGB keyboard control for Asus ROG laptops"
+HOMEPAGE="https://github.com/wroberts/rogauracore"
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="virtual/libusb:="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf
+}
+
+src_compile() {
+ emake
+}
+
+pkg_postinst() {
+ udev_reload
+}
diff --git a/app-laptop/rogauracore/rogauracore-9999.ebuild b/app-laptop/rogauracore/rogauracore-9999.ebuild
index a6678b687a8b..5c7ce4a941bd 100644
--- a/app-laptop/rogauracore/rogauracore-9999.ebuild
+++ b/app-laptop/rogauracore/rogauracore-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit autotools
+inherit autotools udev
if [[ ${PV} = "9999" ]]; then
EGIT_REPO_URI="https://github.com/wroberts/rogauracore.git"
@@ -33,3 +33,7 @@ src_configure() {
src_compile() {
emake
}
+
+pkg_postinst() {
+ udev_reload
+}