summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Willem Fernhout <hfern@fernhout.info>2021-07-15 09:58:50 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-07-16 10:01:52 +0300
commit33eac150eb795219de042536e7dbd6872407d302 (patch)
tree228c7e50b44b9b80783276acdf5eedcb6ed4239e /app-laptop/thinkfan/thinkfan-1.2.2.ebuild
parentvirtual/jdk: copied stable to 1.8.0-r6, dropped old (diff)
downloadgentoo-33eac150eb795219de042536e7dbd6872407d302.tar.gz
gentoo-33eac150eb795219de042536e7dbd6872407d302.tar.bz2
gentoo-33eac150eb795219de042536e7dbd6872407d302.zip
app-laptop/thinkfan: version bump to 1.2.2
This is a maintenance release that fixes a long-standing bug in handling sensors that may disappear at runtime. Closes: https://bugs.gentoo.org/799104 Signed-off-by: Johannes Willem Fernhout <hfern@fernhout.info> Closes: https://github.com/gentoo/gentoo/pull/21650 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-laptop/thinkfan/thinkfan-1.2.2.ebuild')
-rw-r--r--app-laptop/thinkfan/thinkfan-1.2.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-laptop/thinkfan/thinkfan-1.2.2.ebuild b/app-laptop/thinkfan/thinkfan-1.2.2.ebuild
new file mode 100644
index 000000000000..d59a97b5a27a
--- /dev/null
+++ b/app-laptop/thinkfan/thinkfan-1.2.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake readme.gentoo-r1
+
+DESCRIPTION="Simple fan control program for thinkpads"
+HOMEPAGE="https://github.com/vmatare/thinkfan"
+SRC_URI="https://github.com/vmatare/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="atasmart nvidia +yaml"
+
+DEPEND="atasmart? ( dev-libs/libatasmart )
+ yaml? ( dev-cpp/yaml-cpp )"
+
+RDEPEND="${DEPEND}
+ nvidia? ( x11-drivers/nvidia-drivers )"
+
+DOC_CONTENTS="
+ Please read the documentation and copy an appropriate
+ file to /etc/thinkfan.conf.
+"
+
+src_configure() {
+ local mycmakeargs+=(
+ -DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
+ -DUSE_NVML="$(usex nvidia)"
+ -DUSE_ATASMART="$(usex atasmart)"
+ -DUSE_YAML="$(usex yaml)"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ readme.gentoo_create_doc
+}