summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <Matt.Jolly@footclan.ninja>2023-05-13 13:20:43 +1000
committerSam James <sam@gentoo.org>2023-05-13 04:25:00 +0100
commit4c535b8f5917881df93fea006cebc49b022c1cf9 (patch)
treee76358b8551009ecc4237a76a3e1eb914cb9576b /app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.2.3.ebuild
parentdev-libs/openssl-compat: drop 1.1.1s (diff)
downloadgentoo-4c535b8f5917881df93fea006cebc49b022c1cf9.tar.gz
gentoo-4c535b8f5917881df93fea006cebc49b022c1cf9.tar.bz2
gentoo-4c535b8f5917881df93fea006cebc49b022c1cf9.zip
app-laptop/tuxedo-keyboard: add 3.2.3
Closes: https://bugs.gentoo.org/853721 Signed-off-by: Matt Jolly <Matt.Jolly@footclan.ninja> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.2.3.ebuild')
-rw-r--r--app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.2.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.2.3.ebuild b/app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.2.3.ebuild
new file mode 100644
index 000000000000..b3fce1cb74dc
--- /dev/null
+++ b/app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.2.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+CONFIG_CHECK="ACPI_WMI INPUT_SPARSEKMAP"
+
+inherit linux-mod toolchain-funcs
+
+DESCRIPTION="Kernel Module for Tuxedo Keyboard"
+HOMEPAGE="https://github.com/tuxedocomputers/tuxedo-keyboard"
+SRC_URI="https://github.com/tuxedocomputers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BUILD_TARGETS="all"
+MODULE_NAMES="clevo_acpi(tuxedo:${S}:src) clevo_wmi(tuxedo:${S}:src) uniwill_wmi(tuxedo:${S}:src) tuxedo_keyboard(tuxedo:${S}:src) tuxedo_io(tuxedo:${S}:src/tuxedo_io)"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.2.1-rm-unused-functions.patch )
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="CC=$(tc-getBUILD_CC) KDIR=${KV_DIR} V=1 KBUILD_VERBOSE=1"
+}