summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-12-28 15:47:50 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-28 15:47:50 +0100
commit82d9607922cc4d6c00dfa2a83060828a00b99599 (patch)
tree3829315aeec3d1706714370707fdd13d55b5d298 /app-laptop
parentapp-cdr/dvdisaster: Port to EAPI 7 (diff)
downloadgentoo-82d9607922cc4d6c00dfa2a83060828a00b99599.tar.gz
gentoo-82d9607922cc4d6c00dfa2a83060828a00b99599.tar.bz2
gentoo-82d9607922cc4d6c00dfa2a83060828a00b99599.zip
app-laptop/pommed: Port to EAPI 7
Closes: https://bugs.gentoo.org/708514 Package-Manager: Portage-3.0.9, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/pommed/files/pommed-1.39-fno-common.patch22
-rw-r--r--app-laptop/pommed/pommed-1.39-r1.ebuild44
2 files changed, 46 insertions, 20 deletions
diff --git a/app-laptop/pommed/files/pommed-1.39-fno-common.patch b/app-laptop/pommed/files/pommed-1.39-fno-common.patch
new file mode 100644
index 000000000000..4cc66bcc60bf
--- /dev/null
+++ b/app-laptop/pommed/files/pommed-1.39-fno-common.patch
@@ -0,0 +1,22 @@
+--- a/pommed/mactel/nv8600mgt_backlight.c
++++ b/pommed/mactel/nv8600mgt_backlight.c
+@@ -48,7 +48,7 @@
+ #include "../dbus.h"
+
+
+-struct _lcd_bck_info lcd_bck_info;
++extern struct _lcd_bck_info lcd_bck_info;
+
+
+ static int nv8600mgt_inited = 0;
+--- a/pommed/mactel/x1600_backlight.c
++++ b/pommed/mactel/x1600_backlight.c
+@@ -45,7 +45,7 @@
+ #include "../dbus.h"
+
+
+-struct _lcd_bck_info lcd_bck_info;
++extern struct _lcd_bck_info lcd_bck_info;
+
+ static int fd = -1;
+ static char *memory = NULL;
diff --git a/app-laptop/pommed/pommed-1.39-r1.ebuild b/app-laptop/pommed/pommed-1.39-r1.ebuild
index f1350763190b..21e31ee30528 100644
--- a/app-laptop/pommed/pommed-1.39-r1.ebuild
+++ b/app-laptop/pommed/pommed-1.39-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils toolchain-funcs linux-info systemd
+EAPI=7
+
+inherit desktop linux-info systemd
DESCRIPTION="Manage screen and keyboard backlight on Apple MacBook Pro/PowerBook"
HOMEPAGE="http://technologeek.org/projects/pommed/index.html"
@@ -14,23 +15,30 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="gtk X"
-COMMON_DEPEND="media-libs/alsa-lib
- x86? ( sys-apps/pciutils )
- amd64? ( sys-apps/pciutils )
+DEPEND="
+ media-libs/alsa-lib
+ media-libs/audiofile
dev-libs/confuse
- >=sys-apps/dbus-1.1
dev-libs/dbus-glib
+ sys-apps/dbus
sys-libs/zlib
- media-libs/audiofile
+ amd64? ( sys-apps/pciutils )
+ x86? ( sys-apps/pciutils )
gtk? ( x11-libs/gtk+:2 )
- X? ( x11-libs/libX11
+ X? (
+ x11-libs/libX11
x11-libs/libXext
- x11-libs/libXpm )"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig"
-RDEPEND="${COMMON_DEPEND}
+ x11-libs/libXpm
+ )"
+RDEPEND="${DEPEND}
media-sound/alsa-utils
virtual/eject"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
pkg_setup() {
if ! use ppc; then
@@ -41,16 +49,12 @@ pkg_setup() {
fi
}
-src_prepare() {
- epatch "${FILESDIR}/${P}.patch"
-}
-
src_compile() {
- cd "${S}"/pommed
+ cd "${S}"/pommed || die
emake CC="$(tc-getCC)" OFLIB=1
if use gtk; then
- cd "${S}"/gpomme
+ cd "${S}"/gpomme || die
local POFILES=""
for LANG in ${LINGUAS}; do
if [ -f po/${LANG}.po ]; then
@@ -60,7 +64,7 @@ src_compile() {
emake CC="$(tc-getCC)" POFILES="${POFILES}"
fi
if use X; then
- cd "${S}"/wmpomme
+ cd "${S}"/wmpomme || die
emake CC="$(tc-getCC)"
fi
}