summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-31 04:14:04 +0100
committerSam James <sam@gentoo.org>2021-07-31 23:13:41 +0100
commit8f0e7b70246e039e50c9969723eff98495ca7e41 (patch)
tree9a97e7fa4c33a9160f39c9c7dabbdae018fac5a8 /app-laptop
parentapp-backup/bareos: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-8f0e7b70246e039e50c9969723eff98495ca7e41.tar.gz
gentoo-8f0e7b70246e039e50c9969723eff98495ca7e41.tar.bz2
gentoo-8f0e7b70246e039e50c9969723eff98495ca7e41.zip
app-laptop/laptop-mode-tools: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Revbump because the new tmpfiles inherit adds a new dependency (virtual/tmpfiles). Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/laptop-mode-tools/laptop-mode-tools-1.72.2-r2.ebuild (renamed from app-laptop/laptop-mode-tools/laptop-mode-tools-1.72.2-r1.ebuild)6
1 files changed, 4 insertions, 2 deletions
diff --git a/app-laptop/laptop-mode-tools/laptop-mode-tools-1.72.2-r1.ebuild b/app-laptop/laptop-mode-tools/laptop-mode-tools-1.72.2-r2.ebuild
index a9ae177ba5ad..4b6591ed5208 100644
--- a/app-laptop/laptop-mode-tools/laptop-mode-tools-1.72.2-r1.ebuild
+++ b/app-laptop/laptop-mode-tools/laptop-mode-tools-1.72.2-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit multilib systemd udev
+inherit multilib systemd tmpfiles udev
MY_P="${PN}_${PV}"
@@ -66,6 +66,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process laptop-mode.conf
+
if use acpi || use apm; then
if use acpi; then
daemon_name="acpid"