summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOctiabrina Terrien–Puig <octiabrina@myrvogna.net>2021-03-02 02:10:47 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-03-06 17:12:52 +0200
commita2e43367d043c5c9773fda30630303ebad28bd2e (patch)
tree9caa0d0167026e9829344e4b993b7db03df31896 /app-laptop
parentnet-analyzer/ospd: change to setup.py because pyproject is broken (diff)
downloadgentoo-a2e43367d043c5c9773fda30630303ebad28bd2e.tar.gz
gentoo-a2e43367d043c5c9773fda30630303ebad28bd2e.tar.bz2
gentoo-a2e43367d043c5c9773fda30630303ebad28bd2e.zip
app-laptop/i8kutils: update to 1.43 and adoption
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Octiabrina Terrien-Puig <octiabrina@myrvogna.net> Closes: https://github.com/gentoo/gentoo/pull/19729 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/i8kutils/Manifest1
-rw-r--r--app-laptop/i8kutils/files/i8kmon.init19
-rw-r--r--app-laptop/i8kutils/i8kutils-1.43.ebuild49
-rw-r--r--app-laptop/i8kutils/metadata.xml9
4 files changed, 77 insertions, 1 deletions
diff --git a/app-laptop/i8kutils/Manifest b/app-laptop/i8kutils/Manifest
index aa67d983e3cb..c3f10b40ae1c 100644
--- a/app-laptop/i8kutils/Manifest
+++ b/app-laptop/i8kutils/Manifest
@@ -1 +1,2 @@
+DIST i8kutils-1.43.tar.xz 29184 BLAKE2B 3489de1993267eb8aaca1dc00e6c19f68be14b5351715828eee9d4e6abbedbcd3faa58aba5e764de4bbf6cfa41e0a64d011d1d5ea904b261fa3f9842a4501bab SHA512 eed2db9e5864b0dc24e22302ce2abaa54415520a920cfa0be08068b8316a3c2c04b3565cc84164e36fb7ae5bb8b77be55ae179255e03ecd86ea664d85cece456
DIST i8kutils_1.42.tar.xz 37544 BLAKE2B ca8ec63252f43b269ba2a5565fce275aaa6542ebe6f4824d12b194cb0ae8b09dbe354c743ad78af8bcb897e411f1739df464e6c5603d470842de4b59be753984 SHA512 148e8788c50cbaa22f1dd3b72867839f5bc2d91cda70aee74f7c9a3d8542386a44652c5eb8dd9eba0e30400fc6bb72855d3cc7f2dc4284c2529b9cba2eac485b
diff --git a/app-laptop/i8kutils/files/i8kmon.init b/app-laptop/i8kutils/files/i8kmon.init
new file mode 100644
index 000000000000..ed41a2a0a553
--- /dev/null
+++ b/app-laptop/i8kutils/files/i8kmon.init
@@ -0,0 +1,19 @@
+#!/sbin/openrc-run
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ after modules
+}
+
+command="/usr/bin/i8kmon"
+command_args="--nouserconfig"
+command_background=true
+pidfile="/run/${RC_SVCNAME}.pid"
+
+start_pre() {
+ if [ ! -e /proc/i8k ]; then
+ eerror "The dell-smm-hwmon (i8k) driver is not loaded or installed"
+ return 1
+ fi
+}
diff --git a/app-laptop/i8kutils/i8kutils-1.43.ebuild b/app-laptop/i8kutils/i8kutils-1.43.ebuild
new file mode 100644
index 000000000000..d406bfcc3a0f
--- /dev/null
+++ b/app-laptop/i8kutils/i8kutils-1.43.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info systemd toolchain-funcs
+
+DESCRIPTION="Dell Inspiron and Latitude utilities"
+HOMEPAGE="https://launchpad.net/i8kutils"
+SRC_URI="https://launchpad.net/i8kutils/trunk/${PV}/+download/${P/-/_}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/tcl
+ sys-power/acpi
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+pkg_pretend() {
+ # Check for required dell-smm-hwmon (formerly i8k) driver
+ if ! linux_config_exists; then
+ eerror "Unable to check your kernel for dell-smm-hwmon (i8k) support"
+ else
+ CONFIG_CHECK="~I8K"
+ ERROR_I8K="You must have the dell_smm_hwmon driver compiled into your"
+ ERROR_I8K+=" kernel or loaded as a module to use i8kutils' utilities"
+ check_extra_config
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin i8k{ctl,fan,mon}
+ doman i8k{ctl,mon}.1
+ newdoc README.i8kutils README
+ insinto /etc
+ doins i8kmon.conf
+
+ newinitd "${FILESDIR}/i8kmon.init" i8kmon
+ systemd_dounit debian/i8kmon.service
+}
diff --git a/app-laptop/i8kutils/metadata.xml b/app-laptop/i8kutils/metadata.xml
index 000429d96dbe..c9d971e383d6 100644
--- a/app-laptop/i8kutils/metadata.xml
+++ b/app-laptop/i8kutils/metadata.xml
@@ -1,7 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>octiabrina@myrvogna.net</email>
+ <name>Octiabrina Terrien-Puig</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
<remote-id type="launchpad">i8kutils</remote-id>
</upstream>