summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-08-14 11:15:30 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-08-14 11:15:46 +0200
commitbb6d1045102b724b2c0d8da42d926cfb733b0eed (patch)
tree836926d87b1cbfe72bc1286571def2d58a08dc50 /app-laptop
parentdev-db/percona-server: keyword 8.0.25.15 for -riscv (diff)
downloadgentoo-bb6d1045102b724b2c0d8da42d926cfb733b0eed.tar.gz
gentoo-bb6d1045102b724b2c0d8da42d926cfb733b0eed.tar.bz2
gentoo-bb6d1045102b724b2c0d8da42d926cfb733b0eed.zip
app-laptop/rogauracore: new package
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/rogauracore/Manifest1
-rw-r--r--app-laptop/rogauracore/metadata.xml12
-rw-r--r--app-laptop/rogauracore/rogauracore-1.4.ebuild35
-rw-r--r--app-laptop/rogauracore/rogauracore-9999.ebuild35
4 files changed, 83 insertions, 0 deletions
diff --git a/app-laptop/rogauracore/Manifest b/app-laptop/rogauracore/Manifest
new file mode 100644
index 000000000000..6eb00cfc3443
--- /dev/null
+++ b/app-laptop/rogauracore/Manifest
@@ -0,0 +1 @@
+DIST rogauracore-1.4.tar.gz 10305 BLAKE2B 27e94af50d318a3ce87f87236367aea72ee8daa2b0db896daeaa19bb75b6266faca2aca127d6444b759e6b7029c9f2eee1076ca4a197d70c4dfc2c611f5419ed SHA512 5179bfdfa8eeca5d7ac3ec87e4226429fa8d7987dc2d824a73a8a99142ceaf6fbda16f9844a62ecc8c629c44e334f940dff318bb3e2a3057c0bd1620d0f92c36
diff --git a/app-laptop/rogauracore/metadata.xml b/app-laptop/rogauracore/metadata.xml
new file mode 100644
index 000000000000..0a969a8820a3
--- /dev/null
+++ b/app-laptop/rogauracore/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>fordfrog@gentoo.org</email>
+ <description>Miroslav Šulc</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">wroberts/rogauracore</remote-id>
+ <bugs-to>https://github.com/wroberts/rogauracore/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/app-laptop/rogauracore/rogauracore-1.4.ebuild b/app-laptop/rogauracore/rogauracore-1.4.ebuild
new file mode 100644
index 000000000000..a6678b687a8b
--- /dev/null
+++ b/app-laptop/rogauracore/rogauracore-1.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+if [[ ${PV} = "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/wroberts/rogauracore.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/wroberts/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="RGB keyboard control for Asus ROG laptops"
+HOMEPAGE="https://github.com/wroberts/rogauracore"
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="virtual/libusb:="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf
+}
+
+src_compile() {
+ emake
+}
diff --git a/app-laptop/rogauracore/rogauracore-9999.ebuild b/app-laptop/rogauracore/rogauracore-9999.ebuild
new file mode 100644
index 000000000000..a6678b687a8b
--- /dev/null
+++ b/app-laptop/rogauracore/rogauracore-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+if [[ ${PV} = "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/wroberts/rogauracore.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/wroberts/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="RGB keyboard control for Asus ROG laptops"
+HOMEPAGE="https://github.com/wroberts/rogauracore"
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="virtual/libusb:="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf
+}
+
+src_compile() {
+ emake
+}