summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 21:35:03 +0100
committerSam James <sam@gentoo.org>2021-04-19 21:54:04 +0100
commitf31d79bb72edfeeadb1b85a96159a045b2c774e5 (patch)
tree124b85a2cca5a1d61f95ecbc32f89758d503ac7a /app-laptop
parentapp-cdr/extract-xiso: port to EAPI 7 (diff)
downloadgentoo-f31d79bb72edfeeadb1b85a96159a045b2c774e5.tar.gz
gentoo-f31d79bb72edfeeadb1b85a96159a045b2c774e5.tar.bz2
gentoo-f31d79bb72edfeeadb1b85a96159a045b2c774e5.zip
app-laptop/tpb: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/tpb/files/tpb-0.6.4-nvram.patch5
-rw-r--r--app-laptop/tpb/files/tpb-configure-fix.diff5
-rw-r--r--app-laptop/tpb/tpb-0.6.4-r1.ebuild13
3 files changed, 11 insertions, 12 deletions
diff --git a/app-laptop/tpb/files/tpb-0.6.4-nvram.patch b/app-laptop/tpb/files/tpb-0.6.4-nvram.patch
index 1ead9cbe5929..c217b5300c92 100644
--- a/app-laptop/tpb/files/tpb-0.6.4-nvram.patch
+++ b/app-laptop/tpb/files/tpb-0.6.4-nvram.patch
@@ -1,6 +1,5 @@
-diff -Naur tpb-0.6.4-org/src/tpb.c tpb-0.6.4/src/tpb.c
---- tpb-0.6.4-org/src/tpb.c 2005-07-18 16:15:59.000000000 +0200
-+++ tpb-0.6.4/src/tpb.c 2008-05-13 15:15:34.000000000 +0200
+--- a/src/tpb.c
++++ b/src/tpb.c
@@ -523,10 +523,10 @@
/* determine the state of the brightness buttons {{{ */
if(thinkpad_state.brightness_level != last_thinkpad_state.brightness_level) {
diff --git a/app-laptop/tpb/files/tpb-configure-fix.diff b/app-laptop/tpb/files/tpb-configure-fix.diff
index 7dc4683d158b..32df36a1c119 100644
--- a/app-laptop/tpb/files/tpb-configure-fix.diff
+++ b/app-laptop/tpb/files/tpb-configure-fix.diff
@@ -1,6 +1,5 @@
-diff -aur tpb-0.5.1/configure tpb-0.5.1-patched/configure
---- tpb-0.5.1/configure 2003-04-10 04:06:26.000000000 -0400
-+++ tpb-0.5.1-patched/configure 2003-06-30 12:06:41.000000000 -0400
+--- a/configure
++++ b/configure
@@ -790,10 +790,10 @@
# additional options
diff --git a/app-laptop/tpb/tpb-0.6.4-r1.ebuild b/app-laptop/tpb/tpb-0.6.4-r1.ebuild
index ee68708eff7b..660f250b7fc7 100644
--- a/app-laptop/tpb/tpb-0.6.4-r1.ebuild
+++ b/app-laptop/tpb/tpb-0.6.4-r1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit linux-info epatch
+EAPI=7
+
+inherit linux-info
DESCRIPTION="IBM ThinkPad buttons utility"
HOMEPAGE="https://savannah.nongnu.org/projects/tpb/"
@@ -21,10 +22,10 @@ DEPEND="${RDEPEND}"
CONFIG_CHECK="~NVRAM"
ERROR_NVRAM="${P} requires /dev/nvram support (CONFIG_NVRAM)"
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-configure-fix.diff
- epatch "${FILESDIR}"/${P}-nvram.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-configure-fix.diff
+ "${FILESDIR}"/${P}-nvram.patch
+)
src_configure() {
econf \