summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author0xd34df00d <0xd34df00d@gmail.com>2017-02-05 01:33:58 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-05 10:39:01 +0100
commita45ae1e0e667875770581b71e703434aab2fd358 (patch)
tree1ac57ccdf1bd7c7af56ca5ee7dceaf684ccb363a /app-leechcraft/lc-bittorrent
parentdev-libs/libuv: ppc64 stable (bug 607222). (diff)
downloadgentoo-a45ae1e0e667875770581b71e703434aab2fd358.tar.gz
gentoo-a45ae1e0e667875770581b71e703434aab2fd358.tar.bz2
gentoo-a45ae1e0e667875770581b71e703434aab2fd358.zip
app-leechcraft: removed ancient versions 0.6.60, 0.6.65 and 0.6.70.
Closes: https://github.com/gentoo/gentoo/pull/3818
Diffstat (limited to 'app-leechcraft/lc-bittorrent')
-rw-r--r--app-leechcraft/lc-bittorrent/Manifest3
-rw-r--r--app-leechcraft/lc-bittorrent/files/lc-bittorrent-0.6.70-libtorrent1.patch79
-rw-r--r--app-leechcraft/lc-bittorrent/lc-bittorrent-0.6.60.ebuild26
-rw-r--r--app-leechcraft/lc-bittorrent/lc-bittorrent-0.6.65.ebuild26
-rw-r--r--app-leechcraft/lc-bittorrent/lc-bittorrent-0.6.70-r1.ebuild30
-rw-r--r--app-leechcraft/lc-bittorrent/lc-bittorrent-0.6.70.ebuild26
6 files changed, 0 insertions, 190 deletions
diff --git a/app-leechcraft/lc-bittorrent/Manifest b/app-leechcraft/lc-bittorrent/Manifest
deleted file mode 100644
index 1911f838b33a..000000000000
--- a/app-leechcraft/lc-bittorrent/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST leechcraft-0.6.60.tar.xz 5089252 SHA256 669c2325235c3c49dfc9a30d38c1ad08c0a6abf1ebbf2c8d33eca27e976e1b6d SHA512 0bac75f96bfc43c692e8b61ba5e9b6b82d535a78bd310966c36579666feb8b87217a9d74cfe792fa32b57b9b04e158239acbf2422014735d2316cbda2d8b39ec WHIRLPOOL f3056faab0006830afbcf5f3448094e530c908d432cebec731f305f34347e514db55416a911674c28445a3cd4e542136fd053ee5e444b3cf93e086dc9e88428c
-DIST leechcraft-0.6.65.tar.xz 5067580 SHA256 b821fb8716b3ba04862bbb358a738609ead84cd9c86b569fe31c712b48c2a7fd SHA512 94e3cfa42bea572cb2feeaf4c7153c8d7e08e0597d447db5033b72222cea67370e8948d0dd0e2b89585583a88b4ee3df7b32d72dcd624d383e79b9472ceffe30 WHIRLPOOL bc589f46c89351328e25e6e32febdcba8ead639a8d1daf18df7352372d66fb8f8e7e5bbef02d49b6a00a7f5ffa15d66699b79cc73f64ea1bf8b59949fcd81b8a
-DIST leechcraft-0.6.70.tar.xz 5204940 SHA256 3e7f51da0b7eec6df11471ada409d752754f3badc388b8f0adab3f056fabcd45 SHA512 fedf0467e39bd512c937b25f5da62af2be7908831169e1d82d10af43b7c164be2658138663578d7658c3692d5269dd3df9e391744561443f49771edd063ba408 WHIRLPOOL a0aef0bdc11d4b3a3680a055671208db0528bb4744930a0fecab6d1fbf99cc87f4fd8483e98e93357a4c0dda1f3edc1a20a9a725b28ea9003c564469531a2d37
diff --git a/app-leechcraft/lc-bittorrent/files/lc-bittorrent-0.6.70-libtorrent1.patch b/app-leechcraft/lc-bittorrent/files/lc-bittorrent-0.6.70-libtorrent1.patch
deleted file mode 100644
index 429811807639..000000000000
--- a/app-leechcraft/lc-bittorrent/files/lc-bittorrent-0.6.70-libtorrent1.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-commit 5c29ae813099f62affa048efd424e393a2f433c9
-Author: 0xd34df00d <0xd34df00d@gmail.com>
-Date: Wed Sep 3 02:30:48 2014 +0400
-
- [BT] libtorrent-1.0 compatibility.
-
-diff --git a/src/plugins/bittorrent/core.cpp b/src/plugins/bittorrent/core.cpp
-index 2152988..c63de7c 100644
---- a/src/plugins/bittorrent/core.cpp
-+++ b/src/plugins/bittorrent/core.cpp
-@@ -230,9 +230,11 @@ namespace BitTorrent
- setLoggingSettings ();
- tcpPortRangeChanged ();
-
-+#if LIBTORRENT_VERSION_NUM < 010000
- if (XmlSettingsManager::Instance ()->
- property ("EnableMetadata").toBool ())
- Session_->add_extension (&libtorrent::create_metadata_plugin);
-+#endif
- if (XmlSettingsManager::Instance ()->
- property ("EnablePEX").toBool ())
- Session_->add_extension (&libtorrent::create_ut_pex_plugin);
-@@ -1932,10 +1934,17 @@ namespace BitTorrent
- atp.paused = pause;
- atp.duplicate_is_error = true;
- #endif
-+
-+#if LIBTORRENT_VERSION_NUM >= 010000
-+ std::copy (resumeData.constData (),
-+ resumeData.constData () + resumeData.size (),
-+ std::back_inserter (atp.resume_data));
-+#else
- atp.resume_data = new std::vector<char>;
- std::copy (resumeData.constData (),
- resumeData.constData () + resumeData.size (),
- std::back_inserter (*atp.resume_data));
-+#endif
-
- handle = Session_->add_torrent (atp);
- if (XmlSettingsManager::Instance ()->property ("ResolveCountries").toBool ())
-diff --git a/src/plugins/bittorrent/core.h b/src/plugins/bittorrent/core.h
-index 07ac771..46e95cb 100644
---- a/src/plugins/bittorrent/core.h
-+++ b/src/plugins/bittorrent/core.h
-@@ -271,7 +271,7 @@ namespace BitTorrent
- const QVector<bool>& files = QVector<bool> (),
- LeechCraft::TaskParameters params = LeechCraft::NoParameters);
- void KillTask (int);
-- void RemoveTorrent (int, int opt = libtorrent::session::none);
-+ void RemoveTorrent (int, int opt = 0);
- void PauseTorrent (int);
- void ResumeTorrent (int);
- void ForceReannounce (int);
-diff --git a/src/plugins/bittorrent/torrentplugin.cpp b/src/plugins/bittorrent/torrentplugin.cpp
-index e19fc2f..676e544 100644
---- a/src/plugins/bittorrent/torrentplugin.cpp
-+++ b/src/plugins/bittorrent/torrentplugin.cpp
-@@ -555,7 +555,7 @@ namespace LeechCraft
-
- confirm.exec ();
-
-- int roptions = libtorrent::session::none;
-+ int roptions = 0;
- if (confirm.clickedButton () == deleteTorrentsAndFilesButton)
- roptions |= libtorrent::session::delete_files;
- else if (confirm.clickedButton () == deleteTorrentsButton)
-diff --git a/src/plugins/bittorrent/torrenttab.cpp b/src/plugins/bittorrent/torrenttab.cpp
-index fd0cbf7..7f9358b 100644
---- a/src/plugins/bittorrent/torrenttab.cpp
-+++ b/src/plugins/bittorrent/torrenttab.cpp
-@@ -450,7 +450,7 @@ namespace BitTorrent
-
- confirm.exec ();
-
-- int roptions = libtorrent::session::none;
-+ int roptions = 0;
- if (confirm.clickedButton () == deleteTorrentsAndFilesButton)
- roptions |= libtorrent::session::delete_files;
- else if (confirm.clickedButton () == deleteTorrentsButton)
diff --git a/app-leechcraft/lc-bittorrent/lc-bittorrent-0.6.60.ebuild b/app-leechcraft/lc-bittorrent/lc-bittorrent-0.6.60.ebuild
deleted file mode 100644
index bb69fee8091a..000000000000
--- a/app-leechcraft/lc-bittorrent/lc-bittorrent-0.6.60.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-inherit leechcraft
-
-DESCRIPTION="Full-featured BitTorrent client plugin for LeechCraft"
-
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug geoip"
-
-DEPEND="~app-leechcraft/lc-core-${PV}
- net-libs/rb_libtorrent"
-RDEPEND="${DEPEND}
- virtual/leechcraft-task-show
- geoip? ( dev-libs/geoip )"
-
-src_configure(){
- local mycmakeargs="
- $(cmake-utils_use_enable geoip BITTORRENT_GEOIP)
- "
- cmake-utils_src_configure
-}
diff --git a/app-leechcraft/lc-bittorrent/lc-bittorrent-0.6.65.ebuild b/app-leechcraft/lc-bittorrent/lc-bittorrent-0.6.65.ebuild
deleted file mode 100644
index b39954ecc752..000000000000
--- a/app-leechcraft/lc-bittorrent/lc-bittorrent-0.6.65.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-inherit leechcraft
-
-DESCRIPTION="Full-featured BitTorrent client plugin for LeechCraft"
-
-SLOT="0"
-KEYWORDS=" ~amd64 ~x86"
-IUSE="debug geoip"
-
-DEPEND="~app-leechcraft/lc-core-${PV}
- net-libs/rb_libtorrent"
-RDEPEND="${DEPEND}
- virtual/leechcraft-task-show
- geoip? ( dev-libs/geoip )"
-
-src_configure(){
- local mycmakeargs="
- $(cmake-utils_use_enable geoip BITTORRENT_GEOIP)
- "
- cmake-utils_src_configure
-}
diff --git a/app-leechcraft/lc-bittorrent/lc-bittorrent-0.6.70-r1.ebuild b/app-leechcraft/lc-bittorrent/lc-bittorrent-0.6.70-r1.ebuild
deleted file mode 100644
index 461028ea0fad..000000000000
--- a/app-leechcraft/lc-bittorrent/lc-bittorrent-0.6.70-r1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit leechcraft
-
-DESCRIPTION="Full-featured BitTorrent client plugin for LeechCraft"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug geoip"
-
-DEPEND="
- ~app-leechcraft/lc-core-${PV}
- net-libs/rb_libtorrent:=
-"
-RDEPEND="${DEPEND}
- virtual/leechcraft-task-show
- geoip? ( dev-libs/geoip )
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-libtorrent1.patch
-)
-
-src_configure(){
- cmake-utils_src_configure \
- $(cmake-utils_use_enable geoip BITTORRENT_GEOIP)
-}
diff --git a/app-leechcraft/lc-bittorrent/lc-bittorrent-0.6.70.ebuild b/app-leechcraft/lc-bittorrent/lc-bittorrent-0.6.70.ebuild
deleted file mode 100644
index 68acd1f5726f..000000000000
--- a/app-leechcraft/lc-bittorrent/lc-bittorrent-0.6.70.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-inherit leechcraft
-
-DESCRIPTION="Full-featured BitTorrent client plugin for LeechCraft"
-
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug geoip"
-
-DEPEND="~app-leechcraft/lc-core-${PV}
- net-libs/rb_libtorrent"
-RDEPEND="${DEPEND}
- virtual/leechcraft-task-show
- geoip? ( dev-libs/geoip )"
-
-src_configure(){
- local mycmakeargs="
- $(cmake-utils_use_enable geoip BITTORRENT_GEOIP)
- "
- cmake-utils_src_configure
-}