summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author0xd34df00d <0xd34df00d@gmail.com>2020-03-31 15:59:23 -0400
committerAndreas Sturmlechner <asturm@gentoo.org>2020-04-05 21:47:15 +0200
commit6de50b049c258c88dd36ddba9ea47cece0d0cde0 (patch)
tree6c93da4893a278694615bfeb061dfefb99d76b22 /app-leechcraft
parentleechcraft.eclass: add qtcore and qtgui deps (diff)
downloadgentoo-6de50b049c258c88dd36ddba9ea47cece0d0cde0.tar.gz
gentoo-6de50b049c258c88dd36ddba9ea47cece0d0cde0.tar.bz2
gentoo-6de50b049c258c88dd36ddba9ea47cece0d0cde0.zip
app-leechcraft/lc-bittorrent: update geoip dep, bump EAPI
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Georg Rudoy <0xd34df00d@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/15190 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-leechcraft')
-rw-r--r--app-leechcraft/lc-bittorrent/lc-bittorrent-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/app-leechcraft/lc-bittorrent/lc-bittorrent-9999.ebuild b/app-leechcraft/lc-bittorrent/lc-bittorrent-9999.ebuild
index aadccf015c70..7ac2ceed98f5 100644
--- a/app-leechcraft/lc-bittorrent/lc-bittorrent-9999.ebuild
+++ b/app-leechcraft/lc-bittorrent/lc-bittorrent-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit leechcraft
@@ -13,18 +13,18 @@ IUSE="debug geoip"
DEPEND="
~app-leechcraft/lc-core-${PV}
- net-libs/libtorrent-rasterbar
- dev-qt/qtxml:5
dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ net-libs/libtorrent-rasterbar:=
+ geoip? ( dev-libs/libmaxminddb:= )
"
RDEPEND="${DEPEND}
virtual/leechcraft-task-show
- geoip? ( dev-libs/geoip )
"
src_configure() {
local mycmakeargs=(
-DENABLE_BITTORRENT_GEOIP=$(usex geoip)
)
- cmake-utils_src_configure
+ cmake_src_configure
}