summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2019-04-15 15:23:18 -0500
committerWilliam Hubbs <williamh@gentoo.org>2019-04-15 15:26:22 -0500
commite4ec071de04483f6fdc6d1803a6fd5c0cead4b6f (patch)
treebbdf9dd2ce5f69b36a2e2045fac92aa277964040 /app-metrics/consul_exporter/consul_exporter-0.4.0.ebuild
parentsys-apps/hwloc: explicitly disable opencl (diff)
downloadgentoo-e4ec071de04483f6fdc6d1803a6fd5c0cead4b6f.tar.gz
gentoo-e4ec071de04483f6fdc6d1803a6fd5c0cead4b6f.tar.bz2
gentoo-e4ec071de04483f6fdc6d1803a6fd5c0cead4b6f.zip
app-metrics/consul_exporter: Prometheus exporter for consul metrics
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-metrics/consul_exporter/consul_exporter-0.4.0.ebuild')
-rw-r--r--app-metrics/consul_exporter/consul_exporter-0.4.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-metrics/consul_exporter/consul_exporter-0.4.0.ebuild b/app-metrics/consul_exporter/consul_exporter-0.4.0.ebuild
new file mode 100644
index 000000000000..12823ba01c9e
--- /dev/null
+++ b/app-metrics/consul_exporter/consul_exporter-0.4.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/consul_exporter"
+EGIT_COMMIT="v${PV/_rc/-rc.}"
+CONSUL_EXPORTER_COMMIT=75f02d8
+
+DESCRIPTION="Prometheus exporter for consul metrics"
+HOMEPAGE="https://github.com/prometheus/consul_exporter"
+SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=dev-lang/go-1.11
+ dev-util/promu"
+
+RESTRICT="strip test"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${CONSUL_EXPORTER_COMMIT}/" \
+ -e "s/{{.Version}}/${PV}/" \
+ -e "s/-tags netgo/-mod vendor -tags netgo/" \
+ src/${EGO_PN}/.promu.yml || die "Sed failed"
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GO111MODULE=on GOCACHE="${T}/go-cache" promu build -v || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin consul_exporter
+ dodoc {README,CONTRIBUTING}.md
+ popd || die
+ keepdir /var/log/consul_exporter
+ fowners ${PN}:${PN} /var/log/consul_exporter
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}