summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-07-07 01:59:05 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-07-07 01:59:05 +0200
commitba2514dcf0c119994f360e2ebe85e0191d23e184 (patch)
treefb05af441346bd2e99ecdb68506d609d5b1f6e0a /app-metrics/mysqld_exporter/mysqld_exporter-0.12.1_p20200622.ebuild
parentacct-user/mysqld_exporter: new group for app-metrics/mysqld_exporter, UID 308 (diff)
downloadgentoo-ba2514dcf0c119994f360e2ebe85e0191d23e184.tar.gz
gentoo-ba2514dcf0c119994f360e2ebe85e0191d23e184.tar.bz2
gentoo-ba2514dcf0c119994f360e2ebe85e0191d23e184.zip
app-metrics/mysqld_exporter: bump to v0.12.1 snapshot from 2020-06-22
Closes: https://bugs.gentoo.org/730990 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-metrics/mysqld_exporter/mysqld_exporter-0.12.1_p20200622.ebuild')
-rw-r--r--app-metrics/mysqld_exporter/mysqld_exporter-0.12.1_p20200622.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/app-metrics/mysqld_exporter/mysqld_exporter-0.12.1_p20200622.ebuild b/app-metrics/mysqld_exporter/mysqld_exporter-0.12.1_p20200622.ebuild
new file mode 100644
index 000000000000..80f98b838622
--- /dev/null
+++ b/app-metrics/mysqld_exporter/mysqld_exporter-0.12.1_p20200622.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+# uncomment the first setting of MY_PV for a normal release
+# MY_PV="v${PV/_rc/-rc.}"
+# set MY_PV to the full commit hash for a snapshot release
+MY_PV=f5d5289f7627016d8b53b0b3fa7615da8a73b56a
+MYSQLD_EXPORTER_COMMIT=f5d5289f
+
+DESCRIPTION="Prometheus exporter for MySQL server metrics"
+HOMEPAGE="https://github.com/prometheus/mysqld_exporter"
+SRC_URI="https://github.com/prometheus/mysqld_exporter/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+BDEPEND="dev-util/promu"
+
+DEPEND="acct-group/mysqld_exporter
+ acct-user/mysqld_exporter"
+
+RDEPEND="${DEPEND}"
+
+# Comment this for a normal release.
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ default
+
+ sed -i -e "s/{{.Revision}}/${MYSQLD_EXPORTER_COMMIT}/" .promu.yml || die
+}
+
+src_compile() {
+ mkdir -p bin || die
+
+ promu build --prefix bin || die
+
+ # comment this for a normal release.
+ mv bin/${PN}-${MY_PV} bin/${PN} || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc {README,CHANGELOG,CONTRIBUTING}.md
+
+ keepdir /var/lib/mysqld_exporter /var/log/mysqld_exporter
+ fowners ${PN}:${PN} /var/lib/mysqld_exporter /var/log/mysqld_exporter
+ fperms 0770 /var/lib/mysqld_exporter
+
+ newinitd "${FILESDIR}"/${PN}-r1.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}-r1.confd ${PN}
+
+ insinto /etc/logrotate.d/
+ newins "${FILESDIR}"/${PN}.logrotate ${PN}
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ elog "Create \"${EROOT%/}/var/lib/mysqld_exporter/.my.cnf\" to read MySQL credentials from file."
+ else
+ local _replacing_version=
+ for _replacing_version in ${REPLACING_VERSIONS}; do
+ if ! ver_test "${_replacing_version}" -ge "0.11.0"; then
+ elog "Starting with ${PN}-0.11.0, command-line flags will require double dashes (--)."
+ elog "You must update your configuration or ${PN} won't start."
+
+ break
+ fi
+ done
+ fi
+}