summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-07-29 11:16:17 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-07-29 11:16:17 +0200
commite48a881ea3c0e8599a8bbabded089df7596b56c7 (patch)
tree71815bdc7cdff29da93ea6bf33b2f26f38e89dc3 /app-metrics/pushgateway/pushgateway-0.6.0.ebuild
parentapp-emulation/docker: Fix kernel checks (diff)
downloadgentoo-e48a881ea3c0e8599a8bbabded089df7596b56c7.tar.gz
gentoo-e48a881ea3c0e8599a8bbabded089df7596b56c7.tar.bz2
gentoo-e48a881ea3c0e8599a8bbabded089df7596b56c7.zip
app-metrics/pushgateway: Remove old
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'app-metrics/pushgateway/pushgateway-0.6.0.ebuild')
-rw-r--r--app-metrics/pushgateway/pushgateway-0.6.0.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/app-metrics/pushgateway/pushgateway-0.6.0.ebuild b/app-metrics/pushgateway/pushgateway-0.6.0.ebuild
deleted file mode 100644
index 846402c8f22a..000000000000
--- a/app-metrics/pushgateway/pushgateway-0.6.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit user golang-build golang-vcs-snapshot systemd
-
-EGO_PN="github.com/prometheus/pushgateway"
-EGIT_COMMIT="v${PV/_rc/-rc.}"
-GIT_COMMIT="290ff86"
-ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64"
-
-DESCRIPTION="Prometheus push acceptor for ephemeral and batch jobs"
-HOMEPAGE="https://github.com/prometheus/pushgateway"
-SRC_URI="${ARCHIVE_URI}"
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE=""
-
-DEPEND="dev-util/promu"
-
-pkg_setup() {
- enewgroup ${PN}
- enewuser ${PN} -1 -1 -1 ${PN}
-}
-
-src_prepare() {
- default
- sed -i -e "s/{{.Revision}}/${GIT_COMMIT}/" src/${EGO_PN}/.promu.yml || die
-}
-
-src_compile() {
- pushd src/${EGO_PN} || die
- mkdir -p bin || die
- GOPATH="${S}" promu build -v --prefix bin || die
- popd || die
-}
-
-src_install() {
- pushd src/${EGO_PN} || die
- dobin bin/pushgateway
- dodoc {README,CHANGELOG,CONTRIBUTING}.md
- popd || die
- keepdir /var/lib/${PN} /var/log/${PN}
- fowners ${PN}:${PN} /var/lib/${PN} /var/log/${PN}
- newinitd "${FILESDIR}"/${PN}-1.initd ${PN}
- newconfd "${FILESDIR}"/${PN}-1.confd ${PN}
- insinto /etc/logrotate.d
- newins "${FILESDIR}/${PN}.logrotated" "${PN}"
- systemd_dounit "${FILESDIR}/${PN}-1.service"
-}