summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2022-06-01 20:03:58 -0700
committerZac Medico <zmedico@gentoo.org>2022-06-01 20:04:43 -0700
commitcd1a3bb90e04d1365e6696595787019aec4b0ea4 (patch)
tree1e07abe58545e87daa896a6a7811a612a520139d /app-metrics/pushgateway
parentapp-crypt/ophcrack: fix finding qmake (diff)
downloadgentoo-cd1a3bb90e04d1365e6696595787019aec4b0ea4.tar.gz
gentoo-cd1a3bb90e04d1365e6696595787019aec4b0ea4.tar.bz2
gentoo-cd1a3bb90e04d1365e6696595787019aec4b0ea4.zip
app-metrics/pushgateway: add 1.4.3
Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-metrics/pushgateway')
-rw-r--r--app-metrics/pushgateway/Manifest2
-rw-r--r--app-metrics/pushgateway/pushgateway-1.4.3.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/app-metrics/pushgateway/Manifest b/app-metrics/pushgateway/Manifest
index 0a48c33bcf9d..5f1f4524f678 100644
--- a/app-metrics/pushgateway/Manifest
+++ b/app-metrics/pushgateway/Manifest
@@ -1,2 +1,4 @@
DIST pushgateway-1.4.2-deps.tar.xz 28339728 BLAKE2B 6f6e351f1a50e14db8b66b1ecd63eb7e86d28956b0d5f96185daea213b81c66c3bcb4a8db3208310d5023d423668b190eae6c858823f581d90859de82e38762d SHA512 7c1a2e27773e741cfab171a55c3018893c896bcd4eca842fafbcc2ece2b9449a9ca9804176693a7602bb11e84f32dadacfcbbf6f68c0bcb20ef47937aa753275
DIST pushgateway-1.4.2.tar.gz 4264206 BLAKE2B 966593b53184e091400d73c7aa00b147597096ca61adc71964c5ca04c5c7487dbcc4eee652bc47745bb459fa0d3a27bad4936833cd759081c8ae735319582b15 SHA512 7b1da7eecf03c4f7b493d025920e93c52333becf7da6a2d7bdd0eb6f9a2a4a5d08b00786d0796682a465d84750e2c8092cdb1c4ca59a08f15b8b586d6eaa5f1a
+DIST pushgateway-1.4.3-deps.tar.xz 23184228 BLAKE2B a16ce542df626668d94b67989107110a3c89f3d57a60cf75d4b4e7d2b3c90f81871e376358461556818ba59e088264e9d0298700ffef403b54a21fae524478bb SHA512 7c100e8f23c63783a74642cd9e6b1ab2c2a6d6641c5c0c0de00479affa37328b98e947959d0c9d258700536f19596557503777593702687a7386a4bc9c875fb3
+DIST pushgateway-1.4.3.tar.gz 4263325 BLAKE2B 3180e99d0fe883b2ce6111254c557d9e63e8b0d307b520f33093c93fd9f7ce94240823ca45f29bb1246e50d48f48c4a2195da6b0384a433fd48ecfed8eb6a370 SHA512 e41b8cf89c55569d47fae43310e88e548dfa5b598d1d282ae302844444cd1f7d64b7551763dd34aaca16c1807b232861e423caa15ced63599b95a87c78c14a98
diff --git a/app-metrics/pushgateway/pushgateway-1.4.3.ebuild b/app-metrics/pushgateway/pushgateway-1.4.3.ebuild
new file mode 100644
index 000000000000..bf8eb3f672b1
--- /dev/null
+++ b/app-metrics/pushgateway/pushgateway-1.4.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit go-module systemd
+
+GIT_COMMIT="f9dc1c8"
+DESCRIPTION="Prometheus push acceptor for ephemeral and batch jobs"
+HOMEPAGE="https://github.com/prometheus/pushgateway"
+SRC_URI="
+ https://github.com/prometheus/pushgateway/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz
+"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ acct-group/pushgateway
+ acct-user/pushgateway
+"
+DEPEND="${RDEPEND}"
+
+BDEPEND=">=dev-util/promu-0.3.0"
+
+src_prepare() {
+ default
+ sed -i -e 's|{{\.Revision}}|'${GIT_COMMIT}'|g' .promu.yml || die
+}
+
+src_compile() {
+ mkdir -p bin || die
+ promu build -v --prefix bin || die
+}
+
+src_install() {
+ newbin "bin/${P}" "${PN}"
+ dodoc {README,CHANGELOG,CONTRIBUTING}.md
+ keepdir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+ newinitd "${FILESDIR}"/${PN}-1.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}-1.confd ${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotated" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}-1.service"
+}