summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-08-14 15:31:10 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-08-14 15:42:22 +0200
commit4c9737858b85cedab656586e46dbae3a2f85edf0 (patch)
tree871ae26bc42ecfb220de87ee3a4afa8a606a1fde /app-metrics
parentapp-crypt/gnupg: Remove old versions (security cleanup) (diff)
downloadgentoo-4c9737858b85cedab656586e46dbae3a2f85edf0.tar.gz
gentoo-4c9737858b85cedab656586e46dbae3a2f85edf0.tar.bz2
gentoo-4c9737858b85cedab656586e46dbae3a2f85edf0.zip
app-metrics/prometheus: Version bump to 2.11.2
Package-Manager: Portage-2.3.71, Repoman-2.3.16 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'app-metrics')
-rw-r--r--app-metrics/prometheus/Manifest1
-rw-r--r--app-metrics/prometheus/prometheus-2.11.2.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/app-metrics/prometheus/Manifest b/app-metrics/prometheus/Manifest
index 72f2c2550fb4..1cbb83227856 100644
--- a/app-metrics/prometheus/Manifest
+++ b/app-metrics/prometheus/Manifest
@@ -1,4 +1,5 @@
DIST prometheus-2.10.0.tar.gz 11752395 BLAKE2B add59b45e3823d6ab8dcef8f00ba3dda4bb01f8edf891ee142ab790b7145fb2190ee98386dce6aae6afc3ea7bfba3c69749944828c62ed40169e56cda3f53c1c SHA512 eb67fc8a1ecd95689de0aae7e822c40395f82ec4b7f711457d7d504ffaf9a240ad9015a0c568dc93d350cea12cc3db2492bb5fe6300f6193be410b0e00d4463a
DIST prometheus-2.11.0.tar.gz 12133603 BLAKE2B 0036777f95b3e0f6d187129b1ab06c0ead70cd6763a3ace96bd61830e92282072978f04b264bcecf45dc3be78cfffa843a7f3caf6fb5eaecd49e41aecd376cfb SHA512 c6d292f658c99fa6a1e1a9baf0fbcb32e1da7c61bdae1dac1e77385813248c2573c1ac9533dd7b01608b6093d4753454c0f9a2167434fb26c8436ddfc7d97cd2
DIST prometheus-2.11.1.tar.gz 12133604 BLAKE2B 78370f85f9997f776b8acdbdad9db45cc34c8a18a8d467a1a839daca41cbf8ba1e50d5b359282f7062a4d9ba90d7989e13163018ac5043556be5a06dae28dbf9 SHA512 3d238466aad16faecd654f87cab45fe1097119acb241d5f8859d4d8bbeeb007e2c074eb9dc82569e3e1a9ae22a4b9cc0f40160c231d230f2f3f52b4ebf77035c
+DIST prometheus-2.11.2.tar.gz 12132678 BLAKE2B 0b6b9a93b7329c124f901d0acc6130132aa187142f0416e087c12f20b0cd35f8564a27d0df8c0bc811284b9811f446344adf700d6611afac3c5c1131c208b341 SHA512 cecdaf4522885bdf62492667d92475a97c54b04c1e93f48b6078def319fe33f5e28aafbab61e3609413615d6f853e817564fc372e5d1df0d867fe9fa333f6de9
DIST prometheus-2.9.2.tar.gz 11477683 BLAKE2B f0c18c57ff0fe292710174a91080a84ecf0375b4335aacaf4a8e32c842a9346b9fd48888ef8a19a597511c57eb8af7f90cca57d0cc51b9de4558c3f22953d165 SHA512 4cce1827580e49b1659ad492de946a81694c1dab90e079f3f0e56c1991254cf4ecac7f052aac75bf58a0b95d3cf4daa8c15b3e8305a3c089570da40c44a8ccc0
diff --git a/app-metrics/prometheus/prometheus-2.11.2.ebuild b/app-metrics/prometheus/prometheus-2.11.2.ebuild
new file mode 100644
index 000000000000..54264f899cc6
--- /dev/null
+++ b/app-metrics/prometheus/prometheus-2.11.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/prometheus"
+MY_PV=v${PV/_rc/-rc.}
+PROMETHEUS_COMMIT="343d8d7"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus monitoring system and time series database"
+HOMEPAGE="https://github.com/prometheus/prometheus"
+SRC_URI="https://${EGO_PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=dev-lang/go-1.12
+ >=dev-util/promu-0.3.0"
+
+PROMETHEUS_HOME="/var/lib/prometheus"
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup prometheus
+ enewuser prometheus -1 -1 "${PROMETHEUS_HOME}" prometheus
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${PROMETHEUS_COMMIT}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GO111MODULE=on GOPATH="${S}" GOCACHE="${T}/go-cache" promu build -v || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin promtool prometheus
+ dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
+ insinto /etc/prometheus
+ doins documentation/examples/prometheus.yml
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
+ popd || die
+
+ newinitd "${FILESDIR}"/prometheus.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/prometheus-2.0.0_rc0'; then
+ ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
+ ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
+ ewarn "This release requires a clean storage directory and is not compatible with"
+ ewarn "files created by previous beta releases"
+ fi
+}