summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2021-03-14 13:53:01 +0300
committerMikle Kolyada <zlogene@gentoo.org>2021-03-14 13:53:01 +0300
commit5343c3a843c680c4d98089bd8ce4a212020e0021 (patch)
tree1562a5fcdc2365e31c260554fbb583cda1fb57f2 /app-metrics
parentapp-metrics/prometheus: Add systemd unit support (diff)
downloadgentoo-5343c3a843c680c4d98089bd8ce4a212020e0021.tar.gz
gentoo-5343c3a843c680c4d98089bd8ce4a212020e0021.tar.bz2
gentoo-5343c3a843c680c4d98089bd8ce4a212020e0021.zip
app-metrics/prometheus-bin: Version bump (v2.25.0)
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'app-metrics')
-rw-r--r--app-metrics/prometheus-bin/Manifest1
-rw-r--r--app-metrics/prometheus-bin/files/prometheus.service22
-rw-r--r--app-metrics/prometheus-bin/prometheus-bin-2.25.0.ebuild51
3 files changed, 74 insertions, 0 deletions
diff --git a/app-metrics/prometheus-bin/Manifest b/app-metrics/prometheus-bin/Manifest
index 3c1cd89217c5..97fd03a0788f 100644
--- a/app-metrics/prometheus-bin/Manifest
+++ b/app-metrics/prometheus-bin/Manifest
@@ -1 +1,2 @@
DIST prometheus-2.15.2.linux-amd64.tar.gz 59204993 BLAKE2B 700d61063cddea02ca4445257b11b782c3b6fc84ed3d48f8d196c5602819f0d44b218d15b870281293bf0661929b02930b937e66fec34918b81cd3d010a6fa21 SHA512 a3b95fe6101d5587329d84adb18c0c261babe5a909e62ab1a39f42df28c058d311b0b2ea9ecbdad9227789ed83c0fae4a12776348999cda3a70cdc457f6d3611
+DIST prometheus-2.25.0.linux-amd64.tar.gz 66280932 BLAKE2B 3528c9a2c3275d93152281c0083dc224e5a296636ec22628b6b43bc07f64a7c95cf96fb5f9c212c8101b441d9cba40c629d9fab9de3bcca2e18e2ade06ebb3bc SHA512 0dcbdc18fcc99a4c7cee3ce1435812b651b6cea373df4fbc7263c986c2c6c22de1a686ca44eb104ef602e2a1261957a4e0a64d3ba7b24ae4e9b587b852e5ab24
diff --git a/app-metrics/prometheus-bin/files/prometheus.service b/app-metrics/prometheus-bin/files/prometheus.service
new file mode 100644
index 000000000000..ebd8a901d1fd
--- /dev/null
+++ b/app-metrics/prometheus-bin/files/prometheus.service
@@ -0,0 +1,22 @@
+[Unit]
+Description=Prometheus
+Wants=network-online.target
+After=network-online.target
+
+[Service]
+Type=simple
+User=prometheus
+Group=prometheus
+ExecStart=/usr/bin/prometheus \
+ --web.enable-lifecycle \
+ --config.file=/etc/prometheus/prometheus.yml \
+ --storage.tsdb.path="/var/lib/prometheus/data" \
+ --web.console.templates=/etc/prometheus/consoles \
+ --web.console.libraries=/etc/prometheus/console_libraries \
+ --web.listen-address=0.0.0.0:9090 \
+ --web.enable-admin-api
+
+Restart=always
+
+[Install]
+WantedBy=multi-user.target
diff --git a/app-metrics/prometheus-bin/prometheus-bin-2.25.0.ebuild b/app-metrics/prometheus-bin/prometheus-bin-2.25.0.ebuild
new file mode 100644
index 000000000000..da63a8595d37
--- /dev/null
+++ b/app-metrics/prometheus-bin/prometheus-bin-2.25.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+DESCRIPTION="prometheus monitoring system and time series database"
+HOMEPAGE="https://prometheus.io"
+MY_PN=${PN%%-bin}
+MY_P=${MY_PN}-${PV}
+SRC_URI="https://github.com/prometheus/prometheus/releases/download/v${PV}/${MY_P}.linux-amd64.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+QA_PREBUILT=".*"
+RESTRICT="strip"
+
+DEPEND="acct-group/prometheus
+ acct-user/prometheus
+ !app-metrics/prometheus"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}.linux-amd64"
+
+src_install() {
+ dobin prometheus promtool
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ insinto /etc/prometheus
+ doins prometheus.yml
+ dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
+
+ systemd_dounit "${FILESDIR}"/prometheus.service
+ newinitd "${FILESDIR}"/prometheus.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/prometheus-2.0.0_rc0'; then
+ ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
+ ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
+ ewarn "This release requires a clean storage directory and is not compatible with"
+ ewarn "files created by previous beta releases"
+ fi
+}