summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-09-26 16:15:11 -0500
committerWilliam Hubbs <williamh@gentoo.org>2023-09-26 16:27:14 -0500
commit56021ad4e2e71d50ccaeb9b3d402aafae5e52f3c (patch)
tree800e5b313c4f9738fb93d4ec624368f72cd168f7 /app-metrics
parentmedia-video/subtitlecomposer: Stabilize 0.7.1-r3 x86, #914762 (diff)
downloadgentoo-56021ad4e2e71d50ccaeb9b3d402aafae5e52f3c.tar.gz
gentoo-56021ad4e2e71d50ccaeb9b3d402aafae5e52f3c.tar.bz2
gentoo-56021ad4e2e71d50ccaeb9b3d402aafae5e52f3c.zip
app-metrics/prometheus: add 2.47.0
Closes: https://bugs.gentoo.org/913736 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-metrics')
-rw-r--r--app-metrics/prometheus/Manifest3
-rw-r--r--app-metrics/prometheus/prometheus-2.47.0.ebuild72
2 files changed, 75 insertions, 0 deletions
diff --git a/app-metrics/prometheus/Manifest b/app-metrics/prometheus/Manifest
index 63d4ccbe63c2..d049f5612269 100644
--- a/app-metrics/prometheus/Manifest
+++ b/app-metrics/prometheus/Manifest
@@ -4,3 +4,6 @@ DIST prometheus-2.40.4.tar.gz 6156657 BLAKE2B a522b31516f5e26475afa2d59a7074b7de
DIST prometheus-2.43.0-assets.tar.xz 45483188 BLAKE2B 603ba713947954d5c54748cc5778d7c3f6f3ef90abbb73eb3b44269c4b2973290e408d284abe83d30d99107be6007feeb2078d70b4fba71a8b4e612cd7e923a2 SHA512 8a15a3ebbeb8ae27d20d036ee7a9eae09ca8829f8e5b96ebe662e078e57ec02c3654916f705101ea1e371d7b79a4ea9f98b3c3f0433137c7750699e6bf3e0d97
DIST prometheus-2.43.0-deps.tar.xz 261021244 BLAKE2B b2f9af3e1f511135dd782f99aa552c6f20f2196eca95bd88643e4c29c03be81ce5e9fe8818c7700680cbac8c853a9f8c98cc10c517e28cecbf67db257a224019 SHA512 304f49997a8a466811b7a383a2512a47f15f0c0be878af1818698231d7bfbead8974bba31b30fdad59185c00915f45652a68b9f4b52950e81fe6dfa957906358
DIST prometheus-2.43.0.tar.gz 6228230 BLAKE2B d004bb077c70849e7d9e0c28420582475f32d6b5541c12f3c79af02b897fd9df0847c27317cdffe7ccc4183a31e7d0d0535ce980dfe79b3a517a7a6d819645f3 SHA512 d84fcd064224c6b0a9306151ce96052bac53b5c08f6a69ced88e6424c65d1c6143e82a863ac5c9e348a7be97bc2caa38f64f521a5b050e710b474025f6e41014
+DIST prometheus-2.47.0-assets.tar.xz 40992964 BLAKE2B d7eff81d429a482c819269bdb7d67b76dd74b63a70112a2b34ee7eeaa9c9b4049b4c9f2c56aa6468baa9be1454028a1d7b8721bc23c057091e8c1671b266729a SHA512 a8f904a24d8243a26a71b7ab947a465713a6f9185878d0a86ed5c2c665b887f12e74daf6aef6997d290837a3da02160235aef8acb85ba401203d616c34e08e37
+DIST prometheus-2.47.0-deps.tar.xz 337362600 BLAKE2B 03d86183f55cf7ac84e6ccae91fad3bed590a9ba1bd22fbd9b0f3148c6b1367b86af29dad4988c66b28e2b69570940523b1e78ae6ec1b6bd68a744455688beaf SHA512 27edb6aad9bf134c3c061f06b6e96787cd48a19d7ae42c9fa04b86bd6c98b62c1f558030266b0882ad668da268d6794605b017f335d3ad4128a41ca6f5e0d241
+DIST prometheus-2.47.0.tar.gz 6335136 BLAKE2B 10a4d2bb53b8c6cd5f26ab28155673f1d5ea08cc6e070350af9b09d9868dd39a073f9747c0836490be0fc5f33a2d461b5eb8087c3ab469feb940a6e9795c094c SHA512 1d8d91512d3edc7f56bd0e96b398e9680dd5fd39d2ac2e7e3f52d7bccc30ead4e4d0f238886d80d41d980a89c20123e0b29ce6eec9d8799f5581b147f3ef79ea
diff --git a/app-metrics/prometheus/prometheus-2.47.0.ebuild b/app-metrics/prometheus/prometheus-2.47.0.ebuild
new file mode 100644
index 000000000000..0a37f9fcf01e
--- /dev/null
+++ b/app-metrics/prometheus/prometheus-2.47.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd
+GIT_COMMIT=efa34a5840661c29c2e362efa76bc3a70dccb335
+MY_PV=v${PV/_rc/-rc.}
+
+# To create the assets tarball run the following:
+# git checkout <tag>
+# make assets-compress
+# tar -acf <tarball> web/ui
+
+DESCRIPTION="Prometheus monitoring system and time series database"
+HOMEPAGE="https://github.com/prometheus/prometheus"
+SRC_URI="https://github.com/prometheus/prometheus/archive/${MY_PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz
+ https://dev.gentoo.org/~williamh/dist/${P}-assets.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv"
+
+COMMON_DEPEND="acct-group/prometheus
+ acct-user/prometheus"
+DEPEND="!app-metrics/prometheus-bin
+ ${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+BDEPEND=">=dev-util/promu-0.3.0"
+
+RESTRICT=" test"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s/{{.Branch}}/HEAD/" \
+ -e "s/{{.Revision}}/${GIT_COMMIT}/" \
+ -e "s/{{.Version}}/${PV}/" \
+ .promu.yml || die
+ cp -a -u "${WORKDIR}"/web/ui web || die "cp failed"
+}
+
+src_compile() {
+ emake PROMU="${EPREFIX}"/usr/bin/promu common-build plugins
+}
+
+src_install() {
+ dobin prometheus promtool
+ dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ insinto /etc/prometheus
+ doins documentation/examples/prometheus.yml
+ dosym -r /usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym -r /usr/share/prometheus/consoles /etc/prometheus/consoles
+
+ systemd_dounit "${FILESDIR}"/prometheus.service
+ newinitd "${FILESDIR}"/prometheus.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/prometheus-2.0.0_rc0'; then
+ ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
+ ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
+ ewarn "This release requires a clean storage directory and is not compatible with"
+ ewarn "files created by previous beta releases"
+ fi
+}