summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2021-03-21 14:39:23 +0300
committerMikle Kolyada <zlogene@gentoo.org>2021-03-21 14:39:23 +0300
commit70a42ccbbd94a05ccc67170f172b5b36914a943e (patch)
treeba58eae87e8350611f64f232cc1f1740e55ed265 /app-metrics
parentsys-kernel/gentoo-kernel-bin: Stabilize 5.4.105 amd64, #777150 (diff)
downloadgentoo-70a42ccbbd94a05ccc67170f172b5b36914a943e.tar.gz
gentoo-70a42ccbbd94a05ccc67170f172b5b36914a943e.tar.bz2
gentoo-70a42ccbbd94a05ccc67170f172b5b36914a943e.zip
app-metrics/prometheus-bin: Version bump (v2.25.2)
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'app-metrics')
-rw-r--r--app-metrics/prometheus-bin/Manifest1
-rw-r--r--app-metrics/prometheus-bin/prometheus-bin-2.25.2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-metrics/prometheus-bin/Manifest b/app-metrics/prometheus-bin/Manifest
index c9325a826077..783081e5c08c 100644
--- a/app-metrics/prometheus-bin/Manifest
+++ b/app-metrics/prometheus-bin/Manifest
@@ -1 +1,2 @@
DIST prometheus-2.25.0.linux-amd64.tar.gz 66280932 BLAKE2B 3528c9a2c3275d93152281c0083dc224e5a296636ec22628b6b43bc07f64a7c95cf96fb5f9c212c8101b441d9cba40c629d9fab9de3bcca2e18e2ade06ebb3bc SHA512 0dcbdc18fcc99a4c7cee3ce1435812b651b6cea373df4fbc7263c986c2c6c22de1a686ca44eb104ef602e2a1261957a4e0a64d3ba7b24ae4e9b587b852e5ab24
+DIST prometheus-2.25.2.linux-amd64.tar.gz 66277199 BLAKE2B d0b81f9a308edea004347793cb0e522fea0f2c8bb7077ec635ec4046f064cd8eb523d6079b70dd894648ad18205f4c7b2bd8ce8bc6697841c6c59323bd7221ba SHA512 a70beea8042b3199d65431f151086efac33ef0d016dce360be17197794e3c9e4d9277fadbecd0c00bb2814a7c5724cb597695e15d732ab9513dbdf9abc17f74a
diff --git a/app-metrics/prometheus-bin/prometheus-bin-2.25.2.ebuild b/app-metrics/prometheus-bin/prometheus-bin-2.25.2.ebuild
new file mode 100644
index 000000000000..da63a8595d37
--- /dev/null
+++ b/app-metrics/prometheus-bin/prometheus-bin-2.25.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+DESCRIPTION="prometheus monitoring system and time series database"
+HOMEPAGE="https://prometheus.io"
+MY_PN=${PN%%-bin}
+MY_P=${MY_PN}-${PV}
+SRC_URI="https://github.com/prometheus/prometheus/releases/download/v${PV}/${MY_P}.linux-amd64.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+QA_PREBUILT=".*"
+RESTRICT="strip"
+
+DEPEND="acct-group/prometheus
+ acct-user/prometheus
+ !app-metrics/prometheus"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}.linux-amd64"
+
+src_install() {
+ dobin prometheus promtool
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ insinto /etc/prometheus
+ doins prometheus.yml
+ dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
+
+ systemd_dounit "${FILESDIR}"/prometheus.service
+ newinitd "${FILESDIR}"/prometheus.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/prometheus-2.0.0_rc0'; then
+ ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
+ ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
+ ewarn "This release requires a clean storage directory and is not compatible with"
+ ewarn "files created by previous beta releases"
+ fi
+}