summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-07-07 10:08:48 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-07-07 10:09:31 -0500
commit977c64661759cc23ca516517edf08b297c74b275 (patch)
treec591fc1d9b2b0c8301e90bd0d5e589577e0ed34b /app-metrics
parentapp-metrics/prom2json: add myself as maintainer (diff)
downloadgentoo-977c64661759cc23ca516517edf08b297c74b275.tar.gz
gentoo-977c64661759cc23ca516517edf08b297c74b275.tar.bz2
gentoo-977c64661759cc23ca516517edf08b297c74b275.zip
app-metrics/prom2json: 1.3.0 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-metrics')
-rw-r--r--app-metrics/prom2json/Manifest1
-rw-r--r--app-metrics/prom2json/prom2json-1.3.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-metrics/prom2json/Manifest b/app-metrics/prom2json/Manifest
index bd8d9aa7971d..a99918699d37 100644
--- a/app-metrics/prom2json/Manifest
+++ b/app-metrics/prom2json/Manifest
@@ -1 +1,2 @@
DIST prom2json-0.1.0_p20170523.tar.gz 129179 BLAKE2B ef0e42e340d53894c31bff7018b668d8575fc3568584a43dc308955665ac6f59dbabf2d4605bc2a66957df57a29ebb7b3a4eef1f99537eefc2805a5ffd86904f SHA512 824f4c43f4a167dc7dde2f11e84cf482e5cdfa26ab11caf08a5461d525543c3491180f54694c4ae61fdd5dc9763ff16f6e29b332a64dc3ac52fdb7b9c0902571
+DIST prom2json-1.3.0.tar.gz 1646893 BLAKE2B 9b8fcfa4a3e45ee08a57016fa6a7611604cbb578f162f0bf7ff8338f345f98788b75c3ac047ffca95b62020e972c302bc1c44f2f7f00240cfd978f73b8d9c829 SHA512 8f02c7b2616d915e2b4ff5f195a8c2eff89d18417f7396dc02d2aa4cf34711358b0beef6effae9b42a3d6f4b0616c5d3ab995a73ab9e37a4a0ec230adff6f249
diff --git a/app-metrics/prom2json/prom2json-1.3.0.ebuild b/app-metrics/prom2json/prom2json-1.3.0.ebuild
new file mode 100644
index 000000000000..d90427c7afa8
--- /dev/null
+++ b/app-metrics/prom2json/prom2json-1.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+GIT_COMMIT=9180c89ee65bde2cbbe799d06d7d09e30f629984
+
+DESCRIPTION="A tool to scrape a Prometheus client and dump the result as JSON"
+HOMEPAGE="https://github.com/prometheus/prom2json"
+SRC_URI="https://github.com/prometheus/prom2json/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64"
+
+BDEPEND="dev-util/promu"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s/{{.Revision}}/${GIT_COMMIT}/" \
+ -e "s/{{.Version}}/${PV}/" \
+ .promu.yml || die
+}
+
+src_compile() {
+ mkdir bin || die
+ promu build --prefix bin || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc {README,CONTRIBUTING}.md
+}