summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-08-16 16:42:39 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-08-16 16:42:39 +0200
commitbbb16c006c4ce394da352eb74dd1ce7af381467c (patch)
tree7120fd7b3628142011e24be44b0181760a69d947 /app-metrics
parentapp-office/calligraplan: Backport KCalCore 19.08.0 API changes (diff)
downloadgentoo-bbb16c006c4ce394da352eb74dd1ce7af381467c.tar.gz
gentoo-bbb16c006c4ce394da352eb74dd1ce7af381467c.tar.bz2
gentoo-bbb16c006c4ce394da352eb74dd1ce7af381467c.zip
app-metrics/bind_exporter: Update snapshot
Package-Manager: Portage-2.3.71, Repoman-2.3.16 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'app-metrics')
-rw-r--r--app-metrics/bind_exporter/Manifest1
-rw-r--r--app-metrics/bind_exporter/bind_exporter-0.2.0_p20190226.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/app-metrics/bind_exporter/Manifest b/app-metrics/bind_exporter/Manifest
index 6606b65e97c2..d3636d4d4bdd 100644
--- a/app-metrics/bind_exporter/Manifest
+++ b/app-metrics/bind_exporter/Manifest
@@ -1 +1,2 @@
DIST bind_exporter-0.2.0_p20180307.tar.gz 873965 BLAKE2B e59cbd2ccbd13dd60b673c6816e2d4c151e85ed159daa272996081814f7f276bc686b5d6a94db59e41085d57a12974bd2dcb8ef7696dba3940de705dfc800f25 SHA512 63331f877d988a41b86c0204569a1cd19cbfa176be9e811ef8fa5509d0af4a2f7dda0b27f9ba3b0f3df985f7c075f4535225298ce8808f97497d8bfa3b41256d
+DIST bind_exporter-0.2.0_p20190226.tar.gz 874497 BLAKE2B ce04a168be6844d43ed2c358aa6469d5dbae1730825e4c3c038805f4bbf071bfae2936a6a5341832939e3ed249e5d484f2ca0908ac0e717cd2b5ced496c44a49 SHA512 95a8ae6f7c6470345d5a5f7e4e36eae282e5ca74393dd4372342f44732b54a6cc977ae037d6d16ae4ce6a9ac526b2e01721f5468a6469c30ae60ca59dfec8d5a
diff --git a/app-metrics/bind_exporter/bind_exporter-0.2.0_p20190226.ebuild b/app-metrics/bind_exporter/bind_exporter-0.2.0_p20190226.ebuild
new file mode 100644
index 000000000000..06b1f355e34f
--- /dev/null
+++ b/app-metrics/bind_exporter/bind_exporter-0.2.0_p20190226.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/digitalocean/bind_exporter"
+EXPORTER_COMMIT="9289b40af62a455ebd587ed4701dd543f4cc5877"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EXPORTER_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus exporter for BIND"
+HOMEPAGE="https://github.com/digitalocean/bind_exporter"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-util/promu"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+}
+
+src_prepare() {
+ default
+ sed -i -e "/-s$/d" -e "s/{{.Revision}}/${EXPORTER_COMMIT}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ mkdir -p bin || die
+ GOPATH="${S}" promu build -v --prefix bin || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin bin/${PN}
+ dodoc {README,CHANGELOG}.md
+ popd || die
+ keepdir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}
+
+pkg_postinst() {
+ elog "Make sure BIND was built with libxml2 support. You can check with the"
+ elog "following command: named -V | grep libxml2."
+ elog "Configure BIND to open a statistics channel. It's recommended to run"
+ elog "the bind_exporter next to BIND, so it's only necessary to open a port"
+ elog "locally."
+ elog ""
+ elog "statistics-channels {"
+ elog "inet 127.0.0.1 port 8053 allow { 127.0.0.1; };"
+ elog "};"
+}