summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/astrolog/astrolog-5.40-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/astrolog/astrolog-5.40-r2.ebuild')
-rw-r--r--app-misc/astrolog/astrolog-5.40-r2.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/app-misc/astrolog/astrolog-5.40-r2.ebuild b/app-misc/astrolog/astrolog-5.40-r2.ebuild
new file mode 100644
index 000000000000..57b454dba452
--- /dev/null
+++ b/app-misc/astrolog/astrolog-5.40-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="A many featured astrology chart calculation program"
+HOMEPAGE="http://www.astrolog.org/astrolog.htm"
+SRC_URI="http://www.astrolog.org/ftp/ast54unx.shr"
+
+LICENSE="astrolog"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="X"
+
+DEPEND="X? ( x11-libs/libX11 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ sh "${DISTDIR}"/ast54unx.shr || die
+}
+
+src_prepare() {
+ # remove stripping of created binary, dump hardcoded CFLAGS,
+ # respect CC (bug #243606), and CFLAGS (bug #240057)
+ sed \
+ -e 's:strip:#strip:' -e 's:^CFLAGS = :#CFLAGS = :' \
+ -e 's:\tcc :\t$(CC) $(CFLAGS) $(LDFLAGS) :' \
+ -i Makefile || die
+
+ # we use /usr/share/astrolog for config and (optional) ephemeris-data-files
+ sed -i -e "s:~/astrolog:/usr/share/astrolog:g" astrolog.h || die
+
+ # if we use X, we need to add -L/usr/X11R6/lib to compile succesful
+ #use X && sed -i -e "s:-lm -lX11:-lm -lX11 -L/usr/X11R6/lib:g" Makefile
+
+ # if we do NOT use X, we disable it by removing the -lX11 from the Makefile
+ # and remove the "#define X11" and "#define MOUSE" from astrolog.h
+ use X || ( sed -i -e "s:-lm -lX11:-lm:g" Makefile
+ sed -i -e "s:#define X11:/*#define X11:g" astrolog.h
+ sed -i -e "s:#define MOUSE:/*#define MOUSE:g" astrolog.h )
+
+ # any user may have an own astrolog configfile
+ #sed -i -e "s:astrolog.dat:astrolog.dat:g" astrolog.h
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin astrolog
+ dodoc Helpfile.540 README.1ST README.540 Update.540
+ insinto /usr/share/astrolog
+ doins astrolog.dat
+}
+
+pkg_postinst() {
+ ewarn "There is a sample config file /usr/share/astrolog/astrolog.dat"
+ ewarn "astrolog looks in current dir for a file astrolog.dat before"
+ ewarn "using the file in /usr/share/astrolog"
+ ewarn "If you want extended accuracy of astrolog's calculations you"
+ ewarn "can emerge the optional package \"astrolog-ephemeris\" which"
+ ewarn "needs ~4.7 MB additional diskspace for the ephemeris-files"
+}