summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-11-23 00:04:04 +0100
committerMarek Szuba <marecki@gentoo.org>2021-11-23 00:05:43 +0100
commitd28cfddc90de353306ea4dda1039ed73f7d5511a (patch)
treeda100ecc54d8a23a7a0b81ab53f79820b606830a /app-misc/beancounter/beancounter-0.8.10-r2.ebuild
parentdev-python/redis-py: Bump to 4.0.2 (diff)
downloadgentoo-d28cfddc90de353306ea4dda1039ed73f7d5511a.tar.gz
gentoo-d28cfddc90de353306ea4dda1039ed73f7d5511a.tar.bz2
gentoo-d28cfddc90de353306ea4dda1039ed73f7d5511a.zip
app-misc/beancounter: update EAPI 5 -> 8
Closes: https://bugs.gentoo.org/826418 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-misc/beancounter/beancounter-0.8.10-r2.ebuild')
-rw-r--r--app-misc/beancounter/beancounter-0.8.10-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/beancounter/beancounter-0.8.10-r2.ebuild b/app-misc/beancounter/beancounter-0.8.10-r2.ebuild
new file mode 100644
index 000000000000..7435d61063e1
--- /dev/null
+++ b/app-misc/beancounter/beancounter-0.8.10-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-module
+
+DESCRIPTION="Finance performance calculation engine with full data acquisition, SQL support"
+HOMEPAGE="https://dirk.eddelbuettel.com/code/beancounter.html"
+SRC_URI="https://eddelbuettel.com/dirk/code/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="mysql postgres sqlite"
+
+DEPEND="dev-perl/Date-Manip
+ dev-perl/Statistics-Descriptive
+ dev-perl/Finance-YahooQuote
+ dev-perl/libwww-perl
+ mysql? ( dev-perl/DBD-mysql )
+ sqlite? ( dev-perl/DBD-SQLite )
+ postgres? ( dev-perl/DBD-Pg )"
+RDEPEND="${DEPEND}
+ dev-perl/DBI"
+
+mydoc="README example.beancounterrc beancounter_*.txt "
+
+src_install() {
+ perl-module_src_install
+ # rm unwanted READMEs
+ rm "${ED}"/usr/share/doc/${PF}/{README.Debian,README.non-gnu} || die
+}