summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/bijiben
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/bijiben')
-rw-r--r--app-misc/bijiben/Manifest2
-rw-r--r--app-misc/bijiben/bijiben-3.14.2.ebuild42
-rw-r--r--app-misc/bijiben/bijiben-3.16.2.ebuild43
-rw-r--r--app-misc/bijiben/metadata.xml5
4 files changed, 92 insertions, 0 deletions
diff --git a/app-misc/bijiben/Manifest b/app-misc/bijiben/Manifest
new file mode 100644
index 000000000000..7a6b91b0f751
--- /dev/null
+++ b/app-misc/bijiben/Manifest
@@ -0,0 +1,2 @@
+DIST bijiben-3.14.2.tar.xz 621696 SHA256 7998632c83889071c23725ad95867618c72814676a3a3865881e9556714e0537 SHA512 1fc1d4c9ddf3fb674229e96793603769ef77c9aaf43eb142c41450ce79d82e6a5dc659d7e0fe1b7c0256830516f770b32d3b2cf36250172feba2962b71bcb40a WHIRLPOOL 005b103a96457a729b5bb194f2d8973f4785ef302a23825f473c18d75caa699d9d47f8bab27ac44b11f8c327d5d93fb3ce72b46ef57a5f430ca721d95de3adba
+DIST bijiben-3.16.2.tar.xz 658656 SHA256 39c97690e6d0bbed343b2283ea184c89fd49f3c4309af7f56e1b494efd0fd98a SHA512 59e56a961ad66e90e2267ffeb0cdeab312720e82e2a0fb3e78fc1908478f42d657b81b7a3099121a36e150997cdae177f0b25db7e8fb664311550c2d79fab6de WHIRLPOOL 710db7f418be48ead556de0e059f39428bde6277a40174379f797953c8dea20b72ebda15db505cc044fff19df6636932f30b481eae271664ca357825ae8d171a
diff --git a/app-misc/bijiben/bijiben-3.14.2.ebuild b/app-misc/bijiben/bijiben-3.14.2.ebuild
new file mode 100644
index 000000000000..60e5bd6d3412
--- /dev/null
+++ b/app-misc/bijiben/bijiben-3.14.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Note editor designed to remain simple to use"
+HOMEPAGE="https://wiki.gnome.org/Apps/Bijiben"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+# zeitgeist is optional but automagic
+RDEPEND="
+ >=app-misc/tracker-1:=
+ >=dev-libs/glib-2.28:2
+ dev-libs/libxml2
+ >=gnome-extra/evolution-data-server-3
+ >=mail-client/evolution-3
+ gnome-extra/zeitgeist
+ net-libs/gnome-online-accounts
+ net-libs/webkit-gtk:3
+ sys-apps/util-linux
+ >=x11-libs/gtk+-3.11.4:3
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_configure() {
+ gnome2_src_configure \
+ ITSTOOL="$(type -P true)" \
+ --disable-update-mimedb
+}
diff --git a/app-misc/bijiben/bijiben-3.16.2.ebuild b/app-misc/bijiben/bijiben-3.16.2.ebuild
new file mode 100644
index 000000000000..3b7abaa9aeca
--- /dev/null
+++ b/app-misc/bijiben/bijiben-3.16.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Note editor designed to remain simple to use"
+HOMEPAGE="https://wiki.gnome.org/Apps/Bijiben"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# zeitgeist is optional but automagic
+RDEPEND="
+ >=app-misc/tracker-1:=
+ >=dev-libs/glib-2.28:2
+ dev-libs/libxml2
+ >=gnome-extra/evolution-data-server-3.13.90:=
+ >=mail-client/evolution-3
+ gnome-extra/zeitgeist
+ net-libs/gnome-online-accounts
+ net-libs/webkit-gtk:3
+ sys-apps/util-linux
+ >=x11-libs/gtk+-3.11.4:3
+"
+DEPEND="${RDEPEND}
+ dev-libs/appstream-glib
+ >=dev-util/intltool-0.50.1
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_configure() {
+ gnome2_src_configure \
+ ITSTOOL="$(type -P true)" \
+ --disable-update-mimedb
+}
diff --git a/app-misc/bijiben/metadata.xml b/app-misc/bijiben/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/app-misc/bijiben/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>