summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-11-18 15:51:18 -0700
committerTim Harder <radhermit@gentoo.org>2019-11-18 15:54:38 -0700
commit217216968ea8944a215c6e7248fc90c5715fab9e (patch)
tree1e49e94c4f3e29e83ed45897c133997eb4a277e6 /app-misc/binwalk/binwalk-9999.ebuild
parentapp-emulation/docker-compose: 1.25.0 (diff)
downloadgentoo-217216968ea8944a215c6e7248fc90c5715fab9e.tar.gz
gentoo-217216968ea8944a215c6e7248fc90c5715fab9e.tar.bz2
gentoo-217216968ea8944a215c6e7248fc90c5715fab9e.zip
app-misc/binwalk: version bump to 2.2.0
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'app-misc/binwalk/binwalk-9999.ebuild')
-rw-r--r--app-misc/binwalk/binwalk-9999.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/app-misc/binwalk/binwalk-9999.ebuild b/app-misc/binwalk/binwalk-9999.ebuild
index 650ee2faadf9..cd3986d63469 100644
--- a/app-misc/binwalk/binwalk-9999.ebuild
+++ b/app-misc/binwalk/binwalk-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7,3_8} )
inherit distutils-r1
@@ -19,12 +19,17 @@ HOMEPAGE="https://github.com/ReFirmLabs/binwalk"
LICENSE="MIT"
SLOT="0"
-IUSE="graph"
+IUSE="test"
+RESTRICT="!test? ( test )"
-RDEPEND="
- $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7)
- graph? ( dev-python/pyqtgraph[opengl,${PYTHON_USEDEP}] )
-"
+RDEPEND="$(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7)"
+BDEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.2.0-disable-test-coverage.patch )
+
+python_test() {
+ esetup.py test
+}
python_install_all() {
local DOCS=( API.md INSTALL.md README.md )