summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-17 22:55:47 +0100
committerSam James <sam@gentoo.org>2022-10-17 22:56:04 +0100
commit27b398e5d35efb196b4145b35e57ae62f26efc0b (patch)
treef85354e0ddb0c21ded49f0bf341dfc9dba78d117 /app-misc/boxes
parentapp-misc/boxes: new version 2.2.0, patched ebuild to work with clang16 (diff)
downloadgentoo-27b398e5d35efb196b4145b35e57ae62f26efc0b.tar.gz
gentoo-27b398e5d35efb196b4145b35e57ae62f26efc0b.tar.bz2
gentoo-27b398e5d35efb196b4145b35e57ae62f26efc0b.zip
app-misc/boxes: add libunistring dep; add xxd test dep
Bug: https://github.com/gentoo/gentoo/pull/27804 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc/boxes')
-rw-r--r--app-misc/boxes/boxes-2.2.0.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/app-misc/boxes/boxes-2.2.0.ebuild b/app-misc/boxes/boxes-2.2.0.ebuild
index bb96df727114..42da13cbe43f 100644
--- a/app-misc/boxes/boxes-2.2.0.ebuild
+++ b/app-misc/boxes/boxes-2.2.0.ebuild
@@ -12,18 +12,25 @@ SRC_URI="https://github.com/ascii-boxes/boxes/archive/v${PV}.tar.gz -> ${P}.tar.
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
-RDEPEND="dev-libs/libpcre2[pcre32]"
+RDEPEND="
+ dev-libs/libpcre2[pcre32]
+ dev-libs/libunistring:=
+"
DEPEND="${RDEPEND}"
BDEPEND="
sys-devel/bison
sys-devel/flex
+ test? ( app-editors/vim-core )
"
PATCHES=( "${FILESDIR}/${P}-fix-clang16-build.patch" )
src_prepare() {
default
+
sed \
-e 's:STRIP=true:STRIP=false:g' \
-i src/Makefile || die