summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 10:40:42 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:10:48 +0100
commit9f58830f7d854891e3aa42439669149b02cdac34 (patch)
tree9be95ba44505182f12035c5cafbbc2f057f94906 /app-misc/byobu/byobu-5.123-r1.ebuild
parentapp-misc/anki: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-9f58830f7d854891e3aa42439669149b02cdac34.tar.gz
gentoo-9f58830f7d854891e3aa42439669149b02cdac34.tar.bz2
gentoo-9f58830f7d854891e3aa42439669149b02cdac34.zip
app-misc/byobu: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-misc/byobu/byobu-5.123-r1.ebuild')
-rw-r--r--app-misc/byobu/byobu-5.123-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-misc/byobu/byobu-5.123-r1.ebuild b/app-misc/byobu/byobu-5.123-r1.ebuild
new file mode 100644
index 000000000000..058f7590d893
--- /dev/null
+++ b/app-misc/byobu/byobu-5.123-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="A set of profiles for the GNU Screen console window manager (app-misc/screen)"
+HOMEPAGE="http://byobu.co"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P/-/_}.orig.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="screen"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-libs/newt[${PYTHON_MULTI_USEDEP}]
+ ')
+ screen? ( app-misc/screen )
+ !screen? ( app-misc/tmux )"
+
+src_prepare() {
+ default
+
+ python_fix_shebang .
+
+ # Set default system backend to screen
+ if use screen ; then
+ sed -i -e 's/#\(BYOBU_BACKEND\).*/\1="screen"/' etc/byobu/backend || die
+ fi
+}
+
+src_install() {
+ default
+
+ # Create symlinks for backends
+ dosym ${PN} /usr/bin/${PN}-screen
+ dosym ${PN} /usr/bin/${PN}-tmux
+
+ docompress -x /usr/share/doc/${PN}
+}