summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-04-30 16:43:44 +0100
committerSam James <sam@gentoo.org>2021-05-04 22:17:02 +0000
commit2c437afd20857d4652078f520141077aa5f91533 (patch)
treea46a9e4ccc72a24f88a325e4d06c8ea299fce1ad /app-misc/cdctl
parentapp-editors/kakoune: Respect CFLAGS, fix gcc-11 compilation (diff)
downloadgentoo-2c437afd20857d4652078f520141077aa5f91533.tar.gz
gentoo-2c437afd20857d4652078f520141077aa5f91533.tar.bz2
gentoo-2c437afd20857d4652078f520141077aa5f91533.zip
app-misc/cdctl: Respect CFLAGS, fix tc-directly
Closes: https://bugs.gentoo.org/722394 Closes: https://bugs.gentoo.org/779952 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc/cdctl')
-rw-r--r--app-misc/cdctl/cdctl-0.16.ebuild7
-rw-r--r--app-misc/cdctl/files/cdctl-0.16-Makefile.in.patch14
2 files changed, 13 insertions, 8 deletions
diff --git a/app-misc/cdctl/cdctl-0.16.ebuild b/app-misc/cdctl/cdctl-0.16.ebuild
index e552ac85380b..29c33f701e51 100644
--- a/app-misc/cdctl/cdctl-0.16.ebuild
+++ b/app-misc/cdctl/cdctl-0.16.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools
+inherit autotools toolchain-funcs
DESCRIPTION="Utility to control your cd/dvd drive"
HOMEPAGE="http://cdctl.sourceforge.net/"
@@ -20,3 +20,8 @@ src_prepare() {
default
eautoreconf
}
+
+src_configure() {
+ tc-export CC
+ default
+}
diff --git a/app-misc/cdctl/files/cdctl-0.16-Makefile.in.patch b/app-misc/cdctl/files/cdctl-0.16-Makefile.in.patch
index f6f4ad3abdcf..ed338d7d1687 100644
--- a/app-misc/cdctl/files/cdctl-0.16-Makefile.in.patch
+++ b/app-misc/cdctl/files/cdctl-0.16-Makefile.in.patch
@@ -1,9 +1,9 @@
---- cdctl/Makefile.in
-+++ cdctl/Makefile.in
-@@ -1,8 +1,8 @@
- CC=gcc
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -1,8 +1,7 @@
+-CC=gcc
-CFLAGS=-Wall -g
-+CFLAGS:=-Wall -g
++CFLAGS += -Wall
BINS=cdctl sndreset
OBJS=cdctl.o version.o ioctls.o iso_header.o
-DOCS=NEWS NUTSANDBOLTS LICENSE PUBLICKEY README SEGFAULTS
@@ -11,7 +11,7 @@
# NOTE: all man pages are installed in $(mandir)/man1 -- see install-mans
MANS=cdctl.1
MOS=cdctl.mo
-@@ -22,6 +22,8 @@
+@@ -22,6 +21,8 @@ INSTALL = @INSTALL@
INSTALL_DIR = $(INSTALL) -d
INSTALL_DATA = $(INSTALL) -m 644
@@ -20,7 +20,7 @@
all: $(BINS)
cdctl: $(OBJS)
-@@ -35,25 +37,21 @@
+@@ -35,25 +36,21 @@ iso_header.o: iso_header.c
indent:
indent -kr -cdb -sc *.c