summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYumi Tanaka <myknt1184@gmail.com>2019-07-26 07:03:56 +0000
committerAlice Ferrazzi <alicef@gentoo.org>2019-08-02 04:13:12 +0900
commit8ccd44646d823074889dd29914833dc91426b473 (patch)
treedd02683f3215aee4cf28c3e7fd94df069c497dc9 /app-misc/cfiles/cfiles-1.5.ebuild
parentdev-util/cmake: arm64 stable (bug #691114) (diff)
downloadgentoo-8ccd44646d823074889dd29914833dc91426b473.tar.gz
gentoo-8ccd44646d823074889dd29914833dc91426b473.tar.bz2
gentoo-8ccd44646d823074889dd29914833dc91426b473.zip
app-misc/cfiles: New ebuild
It is a terminal file manager with vim like keybindings, written in C using the ncurses library. Signed-off-by: Yumi Tanaka <yumi.tanaka@miraclelinux.com> Signed-off-by: Alice Ferrazzi <alicef@gentoo.org>
Diffstat (limited to 'app-misc/cfiles/cfiles-1.5.ebuild')
-rw-r--r--app-misc/cfiles/cfiles-1.5.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-misc/cfiles/cfiles-1.5.ebuild b/app-misc/cfiles/cfiles-1.5.ebuild
new file mode 100644
index 000000000000..56893ced853c
--- /dev/null
+++ b/app-misc/cfiles/cfiles-1.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A ncurses file manager written in C with vim like keybindings"
+HOMEPAGE="https://github.com/mananapr/cfiles"
+SRC_URI="https://github.com/mananapr/cfiles/archive/v${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ sys-libs/ncurses:=
+ app-text/poppler[utils]
+"
+RDEPEND="${DEPEND}"
+
+src_install(){
+ dobin cfiles
+ dobin scripts/displayimg_uberzug
+ dobin scripts/clearimg_uberzug
+ dobin scripts/displayimg
+ doman cfiles.1
+}