summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2020-10-09 11:22:47 +0000
committerJoonas Niilola <juippis@gentoo.org>2020-10-13 15:06:11 +0300
commit386cdf0c89d99bbc6b0fc75bc9e125210a6fdd16 (patch)
treee6441a0debd8ad3c9429ff998308e57a075c12ac /app-misc/chkcrontab/chkcrontab-1.7-r1.ebuild
parentsci-mathematics/gimps: Version bump to gimps-30.3.6 (diff)
downloadgentoo-386cdf0c89d99bbc6b0fc75bc9e125210a6fdd16.tar.gz
gentoo-386cdf0c89d99bbc6b0fc75bc9e125210a6fdd16.tar.bz2
gentoo-386cdf0c89d99bbc6b0fc75bc9e125210a6fdd16.zip
app-misc/chkcrontab: add python3.9, adjust DISTUTILS_USE_SETUPTOOLS
Closes: https://bugs.gentoo.org/746323 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17859 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc/chkcrontab/chkcrontab-1.7-r1.ebuild')
-rw-r--r--app-misc/chkcrontab/chkcrontab-1.7-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-misc/chkcrontab/chkcrontab-1.7-r1.ebuild b/app-misc/chkcrontab/chkcrontab-1.7-r1.ebuild
new file mode 100644
index 000000000000..7be8fc3cacaf
--- /dev/null
+++ b/app-misc/chkcrontab/chkcrontab-1.7-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="A tool to detect crontab errors"
+HOMEPAGE="https://github.com/lyda/chkcrontab"
+SRC_URI="https://github.com/lyda/chkcrontab/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ doman doc/${PN}.1
+ distutils-r1_python_install_all
+}