summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-31 22:03:20 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-31 22:03:20 +0200
commit5e3d221b8ff309df6ce38212d05157cdca2a45d7 (patch)
treea07a22deb00720357d2f52ef4dd91e2ff448a992 /app-misc/countrycodes
parentapp-misc/cbview: update EAPI 6 -> 8 (diff)
downloadgentoo-5e3d221b8ff309df6ce38212d05157cdca2a45d7.tar.gz
gentoo-5e3d221b8ff309df6ce38212d05157cdca2a45d7.tar.bz2
gentoo-5e3d221b8ff309df6ce38212d05157cdca2a45d7.zip
app-misc/countrycodes: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-misc/countrycodes')
-rw-r--r--app-misc/countrycodes/countrycodes-1.0.5-r4.ebuild (renamed from app-misc/countrycodes/countrycodes-1.0.5-r3.ebuild)16
-rw-r--r--app-misc/countrycodes/files/1.0.5-Makefile.patch29
2 files changed, 23 insertions, 22 deletions
diff --git a/app-misc/countrycodes/countrycodes-1.0.5-r3.ebuild b/app-misc/countrycodes/countrycodes-1.0.5-r4.ebuild
index 01d51733774f..3515c7e85217 100644
--- a/app-misc/countrycodes/countrycodes-1.0.5-r3.ebuild
+++ b/app-misc/countrycodes/countrycodes-1.0.5-r4.ebuild
@@ -1,31 +1,29 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="An ISO 3166 country code finder"
HOMEPAGE="http://www.grigna.com/diego/linux/countrycodes/"
SRC_URI="http://www.grigna.com/diego/linux/${PN}/${P}.tar.gz"
+S="${WORKDIR}/${P}/src"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ~ia64 ~mips ppc ppc64 ~sparc x86"
-S="${WORKDIR}"/${P}/src
+PATCHES=( "${FILESDIR}"/${PV}-Makefile.patch )
-PATCHES=( "${FILESDIR}/${PV}-Makefile.patch" )
-
-src_prepare() {
- default
+src_configure() {
tc-export CC
}
src_install() {
emake \
- prefix="${D}/usr" \
- mandir="${D}/usr/share/man/man1" install
+ prefix="${ED}"/usr \
+ mandir="${ED}"/usr/share/man/man1 install
dosym iso3166 /usr/bin/countrycodes
dosym iso3166.1 /usr/share/man/man1/countrycodes
dodoc ../doc/{Changelog,README}
diff --git a/app-misc/countrycodes/files/1.0.5-Makefile.patch b/app-misc/countrycodes/files/1.0.5-Makefile.patch
index 677e59acc5c0..fab4c82019e1 100644
--- a/app-misc/countrycodes/files/1.0.5-Makefile.patch
+++ b/app-misc/countrycodes/files/1.0.5-Makefile.patch
@@ -1,34 +1,27 @@
-diff --git a/Makefile b/Makefile
-index 9330578..3ff7319 100644
--- a/Makefile
+++ b/Makefile
-@@ -26,13 +26,13 @@ BINMODE=755
+@@ -26,10 +26,9 @@
LOGDIRMODE=700
# Compiler to use
-CC=gcc
-+CC ?= gcc
# Compiler warnings
-WARNINGS= -pedantic -Wall
-+WARNINGS=
++CFLAGS += -pedantic -Wall
# Compiler flags
--CCOPTS = -O2 -fomit-frame-pointer
-+CCOPTS = ${CFLAGS}
-
- # The makefile standards document I read says that I have to put it here...
- SHELL = /bin/sh
-@@ -61,7 +61,7 @@ PROGRAM = iso3166
+ CCOPTS = -O2 -fomit-frame-pointer
+@@ -61,7 +60,7 @@
all: $(PROGRAM)
$(PROGRAM): $(ISO3166OBJ)
- $(CC) $(CCOPTS) $(ISO3166OBJ) -o $@
-+ $(CC) $(CCOPTS) $(LDFLAGS) $(ISO3166OBJ) -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $(ISO3166OBJ) -o $@
clean:
rm -f $(ISO3166OBJ) core defines.h $(PROGRAM)
-@@ -70,8 +70,10 @@ strip:
+@@ -70,8 +69,10 @@
strip $(PROGRAM)
install:
@@ -40,3 +33,13 @@ index 9330578..3ff7319 100644
@$(SEDBIN) $(SEDCMDS) ${docdir}/iso3166.1.in > ${mandir}/iso3166.1
@chown 0.0 ${mandir}/iso3166.1
@echo
+@@ -80,9 +81,6 @@
+ rm -f ${bindir}/$(PROGRAM)
+ rm -f ${mandir}/iso3166.1
+
+-.c.o:
+- $(CC) $(CCOPTS) $(WARNINGS) -c $<
+-
+ $(ISO3166OBJ): common.h defines.h protos.h tables.h
+
+ defines.h: