summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/cwiid/cwiid-20110107-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/cwiid/cwiid-20110107-r2.ebuild')
-rw-r--r--app-misc/cwiid/cwiid-20110107-r2.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/app-misc/cwiid/cwiid-20110107-r2.ebuild b/app-misc/cwiid/cwiid-20110107-r2.ebuild
new file mode 100644
index 000000000000..605c32e14ad2
--- /dev/null
+++ b/app-misc/cwiid/cwiid-20110107-r2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://github.com/abstrakraft/cwiid.git"
+ SRC_URI=""
+ KEYWORDS=""
+ inherit git
+else
+ # git archive --prefix=cwiid-$(date +%Y%m%d)/ \
+ # --format=tar HEAD | bzip2 > cwiid-$(date +%Y%m%d).tar.bz2
+ SRC_URI="http://dev.gentoo.org/~lxnay/cwiid/cwiid-${PV}.tar.bz2"
+ KEYWORDS="~x86 ~amd64"
+fi
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils linux-mod autotools python-single-r1
+
+DESCRIPTION="Library, input driver, and utilities for the Nintendo Wiimote"
+HOMEPAGE="http://abstrakraft.org/cwiid"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="python"
+
+DEPEND="virtual/awk
+ sys-apps/sed
+ sys-devel/bison
+ >=sys-devel/flex-2.5.35
+ virtual/pkgconfig
+ python? ( ${PYTHON_DEPS} )"
+
+RDEPEND="net-wireless/bluez
+ x11-libs/gtk+:2
+ python? ( ${PYTHON_DEPS} )"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+pkg_setup() {
+ CONFIG_CHECK="~BT_L2CAP ~INPUT_UINPUT"
+ linux-mod_pkg_setup
+ use python && python-single-r1_pkg_setup
+}
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]]; then
+ git_src_unpack
+ else
+ unpack ${A}
+ fi
+}
+
+src_prepare() {
+ # Fix broken build system
+ sed -i "s:--disable-ldconfig:--without-ldconfig:g" "${S}"/configure.ac || die
+ sed -i "s:enable_ldconfig:with_ldconfig:g" "${S}"/configure.ac || die
+ epatch "${FILESDIR}"/${P}-underlinking.patch
+ eautoreconf
+}
+src_configure() {
+ econf $(use_with python) --without-ldconfig || die "configure failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+ insinto /lib/udev/rules.d
+ doins "${FILESDIR}/60-${PN}.rules"
+}