summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Coppens <coppens.matthias.abc@gmail.com>2021-02-19 20:35:32 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-03-09 11:17:11 +0200
commite8321f21f7b9431235bb7a429a3f8fdb099a213b (patch)
treef5791ea90ce0bd3129331569a67dd5edffe54ac7 /app-misc/dateutils/dateutils-0.4.8.ebuild
parentdev-python/deepmerge: Remove 0.1.1 (diff)
downloadgentoo-e8321f21f7b9431235bb7a429a3f8fdb099a213b.tar.gz
gentoo-e8321f21f7b9431235bb7a429a3f8fdb099a213b.tar.bz2
gentoo-e8321f21f7b9431235bb7a429a3f8fdb099a213b.zip
app-misc/dateutils: Version bump 0.4.8
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Matthias Coppens <coppens.matthias.abc@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/19548 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc/dateutils/dateutils-0.4.8.ebuild')
-rw-r--r--app-misc/dateutils/dateutils-0.4.8.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-misc/dateutils/dateutils-0.4.8.ebuild b/app-misc/dateutils/dateutils-0.4.8.ebuild
new file mode 100644
index 000000000000..11ced19e9b21
--- /dev/null
+++ b/app-misc/dateutils/dateutils-0.4.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="command line date and time utilities"
+HOMEPAGE="https://www.fresse.org/dateutils/ https://github.com/hroptatyr/dateutils"
+
+case "${PV}" in
+ 9999)
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/hroptatyr/dateutils.git"
+ ;;
+ *)
+ SRC_URI="https://github.com/hroptatyr/dateutils/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+esac
+
+LICENSE="BSD"
+SLOT="0"
+
+BDEPEND="app-arch/xz-utils"
+DEPEND="sys-libs/timezone-data"
+
+# bug 429810
+RDEPEND="${DEPEND}
+ !sys-fabric/dapl"
+
+src_prepare() {
+ default
+ [[ "${PV}" = 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf CFLAGS="${CFLAGS}"
+}