summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2020-07-30 16:05:33 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2020-07-30 16:07:42 -0700
commitb6a980e776954dbc69640c3afc2d1204c3a8d8f5 (patch)
treeef2331239e122bbe541c080ccacc996c970b0483 /app-misc/ddcutil/ddcutil-0.9.9.ebuild
parentdev-python/requests: ALLARCHES stable (via arm, bug #734488) (diff)
downloadgentoo-b6a980e776954dbc69640c3afc2d1204c3a8d8f5.tar.gz
gentoo-b6a980e776954dbc69640c3afc2d1204c3a8d8f5.tar.bz2
gentoo-b6a980e776954dbc69640c3afc2d1204c3a8d8f5.zip
app-misc/ddcutil: version bump
Fixes: https://bugs.gentoo.org/713176 Fixes: https://bugs.gentoo.org/666094 Fixes: https://bugs.gentoo.org/662804 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'app-misc/ddcutil/ddcutil-0.9.9.ebuild')
-rw-r--r--app-misc/ddcutil/ddcutil-0.9.9.ebuild114
1 files changed, 114 insertions, 0 deletions
diff --git a/app-misc/ddcutil/ddcutil-0.9.9.ebuild b/app-misc/ddcutil/ddcutil-0.9.9.ebuild
new file mode 100644
index 000000000000..08aaa306dd03
--- /dev/null
+++ b/app-misc/ddcutil/ddcutil-0.9.9.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic linux-info udev user
+
+DESCRIPTION="Program for querying and changing monitor settings"
+HOMEPAGE="http://www.ddcutil.com/"
+SRC_URI="https://github.com/rockowitz/ddcutil/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="drm introspection usb-monitor user-permissions video_cards_nvidia X"
+REQUIRED_USE="drm? ( X )"
+
+RDEPEND="dev-libs/glib:2
+ sys-apps/i2c-tools
+ virtual/udev
+ drm? ( x11-libs/libdrm )
+ introspection? ( >=dev-libs/gobject-introspection-1.54.0:= )
+ usb-monitor? (
+ dev-libs/hidapi
+ virtual/libusb:1
+ sys-apps/usbutils
+ )
+ X? (
+ x11-libs/libXrandr
+ x11-libs/libX11
+ )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_pretend() {
+ # This program needs /dev/ic2-* devices to communicate with the monitor.
+ CONFIG_CHECK="~I2C_CHARDEV"
+ ERROR_I2C_CHARDEV="You must enable I2C_CHARDEV in your kernel to continue"
+ if use usb-monitor; then
+ CONFIG_CHECK+=" ~HIDRAW ~USB_HIDDEV"
+ ERROR_HIDRAW="HIDRAW is needed to support USB monitors"
+ ERROR_I2C_CHARDEV="USB_HIDDEV is needed to support USB monitors"
+ fi
+
+ # Now do the actual checks setup above
+ check_extra_config
+}
+
+src_prepare() {
+ default
+ eautoreconf
+ sed -i -e "s#usr/local/bin#usr/bin#" data/etc/udev/rules.d/45-ddcutil-usb.rules || die
+}
+
+src_configure() {
+ # Bug 607818.
+ replace-flags -O3 -O2
+
+ local myeconfargs=(
+ $(use_enable drm)
+ $(use_enable usb-monitor usb)
+ $(use_enable X x11)
+ --enable-lib
+ # Please read upstream's note about the original purpose of these flags before re-enabling them:
+ # https://github.com/rockowitz/ddcutil/issues/128
+ # As of 0.9.9 the following no longer compile:
+ # Python3 & CFFI is already broken as of Python 3.7, with future removal;
+ # SWIG : Python3.7 breakage as well PyFileObject vs PyCodeObject
+ --disable-cffi
+ --disable-cython
+ --disable-swig
+ $(use_enable introspection)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ if use user-permissions; then
+ udev_dorules data/etc/udev/rules.d/45-ddcutil-i2c.rules
+ if use usb-monitor; then
+ udev_dorules data/etc/udev/rules.d/45-ddcutil-usb.rules
+ fi
+ fi
+}
+
+pkg_postinst() {
+ if use user-permissions; then
+ enewgroup i2c
+ einfo "To allow non-root users access to the /dev/i2c-* devices, add those"
+ einfo "users to the i2c group: usermod -aG i2c user"
+ einfo "Restart the computer or reload the i2c-dev module to activate"
+ einfo "the new udev rule."
+ einfo "For more information read: http://www.ddcutil.com/i2c_permissions/"
+
+ if use usb-monitor; then
+ enewgroup video
+ einfo "To allow non-root users access to USB monitors, add those users"
+ einfo "to the video group: usermod -aG video user"
+ einfo "Restart the computer, reload the hiddev and hidraw modules, or replug"
+ einfo "the monitor to activate the new udev rule."
+ einfo "For more information read: http://www.ddcutil.com/usb/"
+ fi
+
+ udev_reload
+ fi
+
+ if use video_cards_nvidia; then
+ ewarn "Please read the following webpage on proper usage with the nVidia "
+ ewarn "binary drivers, or it may not work: http://www.ddcutil.com/nvidia/"
+ fi
+}