summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAngelos Kouratzinos <pepitsizous@zoho.com>2019-10-07 01:31:25 +0300
committerJoonas Niilola <juippis@gentoo.org>2019-10-10 08:21:58 +0300
commitdf68f09db2a59b2d4e0dc98ba79eb67bd190f58c (patch)
tree21d451d53cc133800ffd5ec8806116e621633748 /app-misc/dfshow/dfshow-0.8.2_beta.ebuild
parentsys-apps/bleachbit: Bump to 2.3 beta (GTK+3 port) (diff)
downloadgentoo-df68f09db2a59b2d4e0dc98ba79eb67bd190f58c.tar.gz
gentoo-df68f09db2a59b2d4e0dc98ba79eb67bd190f58c.tar.bz2
gentoo-df68f09db2a59b2d4e0dc98ba79eb67bd190f58c.zip
app-misc/dfshow: version bump to 0.8.2 beta
Closes: https://bugs.gentoo.org/696430 Signed-off-by: Angelos Kouratzinos <pepitsizous@zoho.com> Package-Manager: Portage-2.3.76, Repoman-2.3.16 Closes: https://github.com/gentoo/gentoo/pull/13193 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc/dfshow/dfshow-0.8.2_beta.ebuild')
-rw-r--r--app-misc/dfshow/dfshow-0.8.2_beta.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-misc/dfshow/dfshow-0.8.2_beta.ebuild b/app-misc/dfshow/dfshow-0.8.2_beta.ebuild
new file mode 100644
index 000000000000..2b75216f7b96
--- /dev/null
+++ b/app-misc/dfshow/dfshow-0.8.2_beta.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_PV="${PV//_beta/-beta}"
+
+DESCRIPTION="DF-SHOW is a Unix-like rewrite of some of the applications from DF-EDIT"
+HOMEPAGE="https://github.com/roberthawdon/dfshow"
+SRC_URI="https://github.com/roberthawdon/dfshow/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/libconfig
+ sys-libs/ncurses:0=
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -i 's/LDADD = -lncursesw -lm -lconfig/LDADD = -lncursesw -lm -lconfig -ltinfow/' Makefile.am ||
+ die "sed in Makefile.am failed"
+ eautoreconf
+ eautomake --add-missing
+}