summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/dvtm/dvtm-0.14.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/dvtm/dvtm-0.14.ebuild')
-rw-r--r--app-misc/dvtm/dvtm-0.14.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/app-misc/dvtm/dvtm-0.14.ebuild b/app-misc/dvtm/dvtm-0.14.ebuild
new file mode 100644
index 000000000000..56d8eb740282
--- /dev/null
+++ b/app-misc/dvtm/dvtm-0.14.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit savedconfig toolchain-funcs
+
+DESCRIPTION="Dynamic virtual terminal manager"
+HOMEPAGE="http://www.brain-dump.org/projects/dvtm/"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://repo.or.cz/dvtm.git"
+ KEYWORDS=""
+else
+ SRC_URI="http://www.brain-dump.org/projects/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="unicode"
+
+DEPEND="sys-libs/ncurses[unicode?]"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ sed -i \
+ -e 's|FLAGS =|FLAGS +=|' \
+ -e 's|-I/usr/local/include||' \
+ -e 's|-L/usr/local/lib||' \
+ -e 's|-Os||' \
+ config.mk || die "sed config.mk failed"
+ use unicode || {
+ sed -i \
+ -e 's|-lncursesw|-lncurses|' \
+ config.mk || die "sed config.mk failed"
+ }
+ sed -i \
+ -e '/strip/d' \
+ -e 's:@tic :@tic -o ${DESTDIR}${PREFIX}/share/terminfo :g' \
+ Makefile || die "sed Makefile failed"
+
+ restore_config config.h
+}
+
+src_compile() {
+ local msg=""
+ use savedconfig && msg=", please check the configfile"
+ emake CC=$(tc-getCC) ${PN} || die "emake failed${msg}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+
+ insinto /usr/share/${PN}
+ newins config.h ${PF}.config.h
+
+ dodoc README
+
+ save_config config.h
+}
+
+pkg_postinst() {
+ elog "This ebuild has support for user defined configs"
+ elog "Please read this ebuild for more details and re-emerge as needed"
+ elog "if you want to add or remove functionality for ${PN}"
+}