summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2018-03-29 11:53:11 +0200
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2018-03-29 11:53:11 +0200
commit3a8b441ca3250b4b7bc2534720c79ff8a64d4e10 (patch)
treec14060ecabbd3b983b36b3a27bd4646a210cc0e2 /app-misc/dvtm/dvtm-0.15-r3.ebuild
parentapp-misc/dvtm: dev-libs/ncurses blocker needs to be run-time, not build-time (diff)
downloadgentoo-3a8b441ca3250b4b7bc2534720c79ff8a64d4e10.tar.gz
gentoo-3a8b441ca3250b4b7bc2534720c79ff8a64d4e10.tar.bz2
gentoo-3a8b441ca3250b4b7bc2534720c79ff8a64d4e10.zip
app-misc/dvtm: add patch to avoid file collisions with sys-libs/ncurses
Bug: https://bugs.gentoo.org/show_bug.cgi?id=648472 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-misc/dvtm/dvtm-0.15-r3.ebuild')
-rw-r--r--app-misc/dvtm/dvtm-0.15-r3.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/app-misc/dvtm/dvtm-0.15-r3.ebuild b/app-misc/dvtm/dvtm-0.15-r3.ebuild
new file mode 100644
index 000000000000..1de9eac3cdee
--- /dev/null
+++ b/app-misc/dvtm/dvtm-0.15-r3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit savedconfig toolchain-funcs
+
+DESCRIPTION="Dynamic virtual terminal manager"
+HOMEPAGE="http://www.brain-dump.org/projects/dvtm/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://repo.or.cz/dvtm.git"
+else
+ SRC_URI="http://www.brain-dump.org/projects/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=">=sys-libs/ncurses-6.1:0=[unicode]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.15-gentoo.patch
+ "${FILESDIR}"/${PN}-0.15-stop-installing-terminfo.patch
+)
+
+src_prepare() {
+ default
+
+ restore_config config.h
+}
+
+src_compile() {
+ tc-export PKG_CONFIG
+ local msg=""
+ use savedconfig && msg=", please check the configfile"
+ emake CC=$(tc-getCC) ${PN} || die "emake failed${msg}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" STRIP=true install
+
+ insinto /usr/share/${PN}
+ newins config.h ${PF}.config.h
+
+ dodoc README.md
+
+ save_config config.h
+}
+
+pkg_postinst() {
+ elog "This ebuild has support for user defined configs"
+ elog "Please read this ebuild for more details and re-emerge as needed"
+ elog "if you want to add or remove functionality for ${PN}"
+}