summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2017-02-21 10:28:40 +0100
committerGöktürk Yüksek <gokturk@gentoo.org>2017-03-02 00:28:50 -0500
commitce0c1b6e6b09eaefa401b7f2a19a6f3640f281a4 (patch)
treecad0e743ea9b3f520ef7692624b11612d91e29ac /app-misc/elasticsearch/elasticsearch-2.4.3.ebuild
parentsys-apps/systemd: bump to 233 (diff)
downloadgentoo-ce0c1b6e6b09eaefa401b7f2a19a6f3640f281a4.tar.gz
gentoo-ce0c1b6e6b09eaefa401b7f2a19a6f3640f281a4.tar.bz2
gentoo-ce0c1b6e6b09eaefa401b7f2a19a6f3640f281a4.zip
app-misc/elasticsearch: bump to 2.4.4/5.1.2
Package-Manager: portage-2.3.3
Diffstat (limited to 'app-misc/elasticsearch/elasticsearch-2.4.3.ebuild')
-rw-r--r--app-misc/elasticsearch/elasticsearch-2.4.3.ebuild80
1 files changed, 0 insertions, 80 deletions
diff --git a/app-misc/elasticsearch/elasticsearch-2.4.3.ebuild b/app-misc/elasticsearch/elasticsearch-2.4.3.ebuild
deleted file mode 100644
index 57a8b23eb590..000000000000
--- a/app-misc/elasticsearch/elasticsearch-2.4.3.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils systemd user
-
-DESCRIPTION="Open Source, Distributed, RESTful, Search Engine"
-HOMEPAGE="https://www.elastic.co/products/elasticsearch"
-SRC_URI="https://download.elasticsearch.org/${PN}/release/org/${PN}/distribution/tar/${PN}/${PV}/${P}.tar.gz"
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RESTRICT="strip"
-
-RDEPEND="|| ( virtual/jre:1.8 virtual/jre:1.7 )"
-
-pkg_preinst() {
- if has_version '<app-misc/elasticsearch-2.3.2'; then
- export UPDATE_NOTES=1
- fi
-}
-
-pkg_setup() {
- enewgroup ${PN}
- enewuser ${PN} -1 /bin/bash /usr/share/${PN} ${PN}
-}
-
-src_prepare() {
- rm -rf bin/*.{bat,exe} || die
- rm LICENSE.txt || die
-
- default
-}
-
-src_install() {
- keepdir /etc/${PN}
- dodir /etc/${PN}/scripts
-
- insinto /etc/${PN}
- doins config/*
- rm -rf config || die
-
- insinto /usr/share/${PN}
- doins -r ./*
-
- exeinto /usr/share/${PN}/bin
- doexe "${FILESDIR}/elasticsearch-systemd-pre-exec"
-
- chmod +x "${D}"/usr/share/${PN}/bin/* || die
-
- keepdir /var/{lib,log}/${PN}
- keepdir /usr/share/${PN}/plugins
-
- systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles.d" "${PN}.conf"
-
- insinto /etc/sysctl.d
- newins "${FILESDIR}/${PN}.sysctl.d" "${PN}.conf"
-
- newinitd "${FILESDIR}/${PN}.init6" "${PN}"
- newconfd "${FILESDIR}/${PN}.conf2" "${PN}"
- systemd_newunit "${FILESDIR}"/${PN}.service5 "${PN}.service"
-}
-
-pkg_postinst() {
- elog
- elog "You may create multiple instances of ${PN} by"
- elog "symlinking the init script:"
- elog "ln -sf /etc/init.d/${PN} /etc/init.d/${PN}.instance"
- elog
- elog "Please make sure you put elasticsearch.yml and logging.yml"
- elog "into the configuration directory of the instance:"
- elog "/etc/${PN}/instance"
- elog
- if ! [ -z ${UPDATE_NOTES} ]; then
- elog "This update changes some configuration variables. Please review"
- elog "${EROOT%/}/etc/conf.d/elasticsearch before restarting your services."
- fi
-}