summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/empty/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/empty/files')
-rw-r--r--app-misc/empty/files/empty-respect-LDFLAGS.patch11
-rw-r--r--app-misc/empty/files/overflow-fixes.patch20
2 files changed, 31 insertions, 0 deletions
diff --git a/app-misc/empty/files/empty-respect-LDFLAGS.patch b/app-misc/empty/files/empty-respect-LDFLAGS.patch
new file mode 100644
index 000000000000..f839afcf28c9
--- /dev/null
+++ b/app-misc/empty/files/empty-respect-LDFLAGS.patch
@@ -0,0 +1,11 @@
+--- empty-0.6.18b/Makefile
++++ empty-0.6.18b/Makefile
+@@ -16,7 +16,7 @@
+ PREFIX = /usr/local
+
+ all:
+- ${CC} ${CFLAGS} -Wall ${LIBS} -o empty empty.c
++ ${CC} ${CFLAGS} ${LDFLAGS} empty.c ${LIBS} -o empty
+
+ FreeBSD: all
+ NetBSD: all
diff --git a/app-misc/empty/files/overflow-fixes.patch b/app-misc/empty/files/overflow-fixes.patch
new file mode 100644
index 000000000000..96dd18024a03
--- /dev/null
+++ b/app-misc/empty/files/overflow-fixes.patch
@@ -0,0 +1,20 @@
+--- empty.c.orig 2009-07-27 18:26:42.000000000 +0100
++++ empty.c 2011-12-22 17:17:11.037090159 +0000
+@@ -584,7 +584,7 @@
+
+ for (i = 1; i < argc; i++) {
+ strncat(buf, " ", 1);
+- strncat(buf, argv[i], sizeof(buf));
++ strncat(buf, argv[i], sizeof(buf) -1);
+ }
+
+ (void)syslog(LOG_NOTICE, "forked %s", buf);
+@@ -686,7 +686,7 @@
+ while ((dent = readdir(dir)) != NULL) {
+ if (!strncmp(fmask, dent->d_name, len)) {
+ strncpy(fname, dent->d_name, sizeof(fname) - 1);
+- fname[sizeof(buf) - 1] = '\0';
++ fname[MAXPATHLEN - 1] = '\0';
+
+ strtok(fname, sep); /* empty */
+ strtok(NULL, sep); /* PPID */