summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-01-13 11:38:00 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-01-13 11:47:37 +0100
commitb8ed0369ea828c98c2a2daad53879ddb7f6e3621 (patch)
tree35736b3bf97c1b6c48f7a1da9b5bb14080b9334e /app-misc/fdupes/fdupes-2.1.2.ebuild
parentmedia-gfx/sane-backends: Depend on app-text/poppler[cairo] (diff)
downloadgentoo-b8ed0369ea828c98c2a2daad53879ddb7f6e3621.tar.gz
gentoo-b8ed0369ea828c98c2a2daad53879ddb7f6e3621.tar.bz2
gentoo-b8ed0369ea828c98c2a2daad53879ddb7f6e3621.zip
app-misc/fdupes: Bump to version 2.1.2
Closes: https://github.com/gentoo/gentoo/pull/16441 Closes: https://bugs.gentoo.org/720920 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-misc/fdupes/fdupes-2.1.2.ebuild')
-rw-r--r--app-misc/fdupes/fdupes-2.1.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/fdupes/fdupes-2.1.2.ebuild b/app-misc/fdupes/fdupes-2.1.2.ebuild
new file mode 100644
index 000000000000..78acd8f3a926
--- /dev/null
+++ b/app-misc/fdupes/fdupes-2.1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Identify/delete duplicate files residing within specified directories"
+HOMEPAGE="https://github.com/adrianlopezroche/fdupes"
+SRC_URI="https://github.com/adrianlopezroche/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+ncurses"
+
+RDEPEND="
+ dev-libs/libpcre2[pcre32]
+ ncurses? ( sys-libs/ncurses:0= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( CHANGES CONTRIBUTORS README )
+
+src_configure() {
+ econf $(use_with ncurses)
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}