summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2024-03-06 08:56:03 -0800
committerZac Medico <zmedico@gentoo.org>2024-03-06 09:32:37 -0800
commitaebb8f3f05d06fe931816c40d5880ff7357552e0 (patch)
tree90a225a6229c57323670ced27848974a6b14dbd5 /app-misc/filebus/filebus-0.3.5.ebuild
parentapp-editors/logseq-desktop-bin: drop 0.10.5 (diff)
downloadgentoo-aebb8f3f05d06fe931816c40d5880ff7357552e0.tar.gz
gentoo-aebb8f3f05d06fe931816c40d5880ff7357552e0.tar.bz2
gentoo-aebb8f3f05d06fe931816c40d5880ff7357552e0.zip
app-misc/filebus: enable PEP517 build
Closes: https://bugs.gentoo.org/909879 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-misc/filebus/filebus-0.3.5.ebuild')
-rw-r--r--app-misc/filebus/filebus-0.3.5.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/app-misc/filebus/filebus-0.3.5.ebuild b/app-misc/filebus/filebus-0.3.5.ebuild
index c8eae8478dcd..71ab1c8994b0 100644
--- a/app-misc/filebus/filebus-0.3.5.ebuild
+++ b/app-misc/filebus/filebus-0.3.5.ebuild
@@ -1,9 +1,10 @@
-# Copyright 2021-2023 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python3_{9,10,11} )
+PYTHON_COMPAT=( python3_{10,11,12} )
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
@@ -23,7 +24,7 @@ RDEPEND="
dev-python/filelock[${PYTHON_USEDEP}]
inotify? ( dev-python/watchdog[${PYTHON_USEDEP}] )
)"
-BDEPEND="${RDEPEND}"
+BDEPEND="${DISTUTILS_DEPS} ${RDEPEND}"
src_prepare() {
default