summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-09-12 13:56:55 +0200
committerMichał Górny <mgorny@gentoo.org>2018-09-18 08:51:23 +0200
commit206356bcbe465d0996fe8d04fb2e15551ca0f6f0 (patch)
tree9eda147459078e0194e85564ef38c9e35a970adf /app-misc/fujiplay/fujiplay-1.33-r1.ebuild
parentdev-python/py-amqp: remove unused patch(es) (diff)
downloadgentoo-206356bcbe465d0996fe8d04fb2e15551ca0f6f0.tar.gz
gentoo-206356bcbe465d0996fe8d04fb2e15551ca0f6f0.tar.bz2
gentoo-206356bcbe465d0996fe8d04fb2e15551ca0f6f0.zip
app-misc/fujiplay: EAPI7, fix HOMEPAGE/SRC_URI, improve ebuild
Closes: https://bugs.gentoo.org/665772 Closes: https://github.com/gentoo/gentoo/pull/9843
Diffstat (limited to 'app-misc/fujiplay/fujiplay-1.33-r1.ebuild')
-rw-r--r--app-misc/fujiplay/fujiplay-1.33-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-misc/fujiplay/fujiplay-1.33-r1.ebuild b/app-misc/fujiplay/fujiplay-1.33-r1.ebuild
new file mode 100644
index 000000000000..796eccb8d312
--- /dev/null
+++ b/app-misc/fujiplay/fujiplay-1.33-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utility for Fujifilm/Leica digital cameras (via serial port)"
+HOMEPAGE="https://www.math.u-psud.fr/~bousch/fujiplay.html"
+SRC_URI="https://www.math.u-psud.fr/~bousch/${PN}.tgz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}"
+
+PATCHES=( "${FILESDIR}"/${P}-unterminated-strings.patch )
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin fujiplay yycc2ppm
+ dodoc README fujiplay.lsm mx700-commands.html
+ emake all clean
+}
+
+pkg_postinst() {
+ ln -s /dev/ttyS0 /dev/fujifilm || die
+ elog "A symbolic link /dev/ttyS0 -> /dev/fujifilm was created."
+ elog "You may want to create a serial group to allow non-root"
+ elog "members R/W access to the serial device."
+ elog
+}
+
+pkg_postrm() {
+ rm -f /dev/fujifilm || die
+ elog
+ elog "The symbolic link /dev/fujifilm was removed."
+ elog
+}