summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-11-05 08:28:11 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-11-05 08:36:33 +0000
commitf867c11bb15d204285c8cd1e8208e675a0a8fe2e (patch)
treec131fa6beddf22daae684e4cbe811f778806c2b5 /app-misc/golly/files
parentsys-apps/hwloc: timeout bump to 2.3.0, fix multiple issues (diff)
downloadgentoo-f867c11bb15d204285c8cd1e8208e675a0a8fe2e.tar.gz
gentoo-f867c11bb15d204285c8cd1e8208e675a0a8fe2e.tar.bz2
gentoo-f867c11bb15d204285c8cd1e8208e675a0a8fe2e.zip
app-misc/golly: bump up to 4.0
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'app-misc/golly/files')
-rw-r--r--app-misc/golly/files/golly-4.0-CFLAGS.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-misc/golly/files/golly-4.0-CFLAGS.patch b/app-misc/golly/files/golly-4.0-CFLAGS.patch
new file mode 100644
index 000000000000..3ac729df93ef
--- /dev/null
+++ b/app-misc/golly/files/golly-4.0-CFLAGS.patch
@@ -0,0 +1,24 @@
+--- a/lua/Makefile
++++ b/lua/Makefile
+@@ -13,7 +13,7 @@ osx_ge = $(shell if [ $(OS_VERSION) -ge $(1) ] ; then echo "$(2)"; else echo "$(
+
+ CFLAGS += $(call osx_ge,10,"-mmacosx-version-min=10.10","")
+ else
+-CFLAGS = -O2 -Wall -Wextra -DLUA_USE_LINUX
++CFLAGS += -Wall -Wextra -DLUA_USE_LINUX
+ endif
+
+ OBJ_FILES = lapi.o lcode.o lctype.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o \
+--- a/lua/Makefile
++++ b/lua/Makefile
+@@ -25,8 +25,8 @@ OBJ_FILES = lapi.o lcode.o lctype.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o
+ all: $(LUA_LIB)
+
+ $(LUA_LIB): $(OBJ_FILES)
+- ar rcu $@ $(OBJ_FILES)
+- ranlib $@
++ $(AR) rcu $@ $(OBJ_FILES)
++ $(RANLIB) $@
+
+ clean:
+ rm -f $(LUA_LIB) $(OBJ_FILES)