summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-04-14 17:03:02 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-04-14 17:33:42 +0200
commit21df94fa092d1be6344a53e98726876f71feb1b1 (patch)
treed3c6d0fcfe5808b35cd4a9b3b672c346a5377190 /app-misc/golly/golly-4.2.ebuild
parentapp-arch/dtrx: enable py3.12 compat (diff)
downloadgentoo-21df94fa092d1be6344a53e98726876f71feb1b1.tar.gz
gentoo-21df94fa092d1be6344a53e98726876f71feb1b1.tar.bz2
gentoo-21df94fa092d1be6344a53e98726876f71feb1b1.zip
app-misc/golly: enable py3.12 compat
Closes: https://bugs.gentoo.org/929331 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-misc/golly/golly-4.2.ebuild')
-rw-r--r--app-misc/golly/golly-4.2.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/app-misc/golly/golly-4.2.ebuild b/app-misc/golly/golly-4.2.ebuild
deleted file mode 100644
index a35f1c8f3a23..000000000000
--- a/app-misc/golly/golly-4.2.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-WX_GTK_VER=3.2-gtk3
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit desktop python-single-r1 toolchain-funcs wxwidgets xdg
-
-DESCRIPTION="simulator for Conway's Game of Life and other cellular automata"
-HOMEPAGE="http://golly.sourceforge.net/
- https://sourceforge.net/projects/golly/"
-SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
-S="${WORKDIR}/${P}-src"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- sys-libs/zlib
- virtual/opengl
- x11-libs/wxGTK:${WX_GTK_VER}[X,curl,opengl,sdl,tiff]
- ${PYTHON_DEPS}
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}"/${PN}-4.0-CFLAGS.patch )
-
-pkg_setup() {
- python-single-r1_pkg_setup
- setup-wxwidgets
-}
-
-src_compile() {
- local -a mymakeopts=(
- ENABLE_SOUND=yes
- GOLLYDIR="${EPREFIX}/usr/share/${PN}"
- PYTHON=${EPYTHON}
- WX_CONFIG=${WX_CONFIG}
- AR="$(tc-getAR)"
- CC="$(tc-getCC)"
- CXX="$(tc-getCXX)"
- CXXC="$(tc-getCXX)"
- RANLIB="$(tc-getRANLIB)"
- )
- emake -C gui-wx -f makefile-gtk "${mymakeopts[@]}"
-}
-
-src_install() {
- # Has no 'make install', let's install files manually.
- exeinto /usr/bin
- doexe golly bgolly
-
- insinto /usr/share/${PN}
- doins -r Help Patterns Scripts Rules docs
-
- newicon --size 32 gui-wx/icons/appicon.xpm ${PN}.xpm
- make_desktop_entry ${PN} "Golly" ${PN} "Science"
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}