summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-01-07 22:02:58 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-01-07 22:09:43 +0100
commit56f71ebacff58371df147f4520b8b69d69601593 (patch)
treee742909da1bc09b3b8b3400a10c115025b80b203 /app-misc/graphlcd-base/graphlcd-base-2.0.2.ebuild
parentapp-arch/plzip: Bump to 1.9 (diff)
downloadgentoo-56f71ebacff58371df147f4520b8b69d69601593.tar.gz
gentoo-56f71ebacff58371df147f4520b8b69d69601593.tar.bz2
gentoo-56f71ebacff58371df147f4520b8b69d69601593.zip
app-misc/graphlcd-base: bump to version 2.0.2
Please note, that I am adding here on purpose stable keywords, as its the same version, as currently 2.0.1 is. The only difference is, that my musl patch for compile fixes got merged, which is also already applied to 2.0.1, but upstream bumped after merging the patch to 2.0.2. But in order not to confuse users, I am bumping to official version. Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-misc/graphlcd-base/graphlcd-base-2.0.2.ebuild')
-rw-r--r--app-misc/graphlcd-base/graphlcd-base-2.0.2.ebuild91
1 files changed, 91 insertions, 0 deletions
diff --git a/app-misc/graphlcd-base/graphlcd-base-2.0.2.ebuild b/app-misc/graphlcd-base/graphlcd-base-2.0.2.ebuild
new file mode 100644
index 000000000000..1bb09fbd69cc
--- /dev/null
+++ b/app-misc/graphlcd-base/graphlcd-base-2.0.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature toolchain-funcs udev
+
+DESCRIPTION="Contains the lowlevel lcd drivers for GraphLCD"
+HOMEPAGE="https://projects.vdr-developer.org/projects/graphlcd-base"
+SRC_URI="https://projects.vdr-developer.org/git/${PN}.git/snapshot/${P}.tar.bz2"
+
+KEYWORDS="amd64 x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="fontconfig freetype graphicsmagick imagemagick lcd_devices_ax206dpf lcd_devices_picolcd_256x64 lcd_devices_vnc"
+REQUIRED_USE="?? ( graphicsmagick imagemagick )"
+
+RDEPEND="
+ dev-libs/libhid
+ net-libs/libvncserver
+ freetype? ( media-libs/freetype:2= )
+ fontconfig? ( media-libs/fontconfig:1.0= )
+ graphicsmagick? ( media-gfx/graphicsmagick:0/1.3[cxx] )
+ imagemagick? ( <media-gfx/imagemagick-7 )
+ lcd_devices_ax206dpf? ( virtual/libusb:0 )
+ lcd_devices_picolcd_256x64? ( virtual/libusb:0 )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "HISTORY" "README" "TODO" "docs/." )
+
+PATCHES=( "${FILESDIR}/${PN}-2.0.0-musl.patch" )
+
+src_prepare() {
+ default
+
+ # Change '/usr/local/' to '/usr'
+ # Change '/usr/lib' to '/usr/$(get_libdir)'
+ sed -e "34s:/usr/local:/usr:" -e "37s:/lib:/$(get_libdir):" -i Make.config || die
+
+ # Fix newer GCC version with the Futaba MDM166A lcd driver
+ sed -e "s:0xff7f0004:(int) 0xff7f0004:" -i glcddrivers/futabaMDM166A.c || die
+
+ tc-export CC CXX
+}
+
+src_configure() {
+ # Build optional drivers
+ if use lcd_devices_ax206dpf; then
+ sed -e "78s:#::" -i Make.config || die
+ fi
+ if use lcd_devices_picolcd_256x64; then
+ sed -e "81s:#::" -i Make.config || die
+ fi
+ if ! use lcd_devices_vnc; then
+ sed -e "72s:1:0:" -i Make.config || die
+ fi
+
+ # Build optional features
+ if ! use freetype; then
+ sed -e "59s:HAVE:#HAVE:" -i Make.config || die
+ fi
+ if ! use fontconfig; then
+ sed -e "62s:HAVE:#HAVE:" -i Make.config || die
+ fi
+ if use graphicsmagick; then
+ sed -e "69s:#::" -i Make.config || die
+ fi
+ if use imagemagick; then
+ sed -e "68s:#::" -i Make.config || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" UDEVRULESDIR="/lib/udev/rules.d" install
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ udev_reload
+
+ optfeature "supporting the logitech g15 keyboard lcd." app-misc/g15daemon
+}
+
+pkg_postrm() {
+ udev_reload
+}