summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/kanatest/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/kanatest/files')
-rw-r--r--app-misc/kanatest/files/kanatest-0.4.8+gtk-2.22.patch23
-rw-r--r--app-misc/kanatest/files/kanatest-0.4.8-autoconf.patch13
-rw-r--r--app-misc/kanatest/files/kanatest-0.4.8-cflags.patch13
3 files changed, 49 insertions, 0 deletions
diff --git a/app-misc/kanatest/files/kanatest-0.4.8+gtk-2.22.patch b/app-misc/kanatest/files/kanatest-0.4.8+gtk-2.22.patch
new file mode 100644
index 000000000000..5db2c1e0adaf
--- /dev/null
+++ b/app-misc/kanatest/files/kanatest-0.4.8+gtk-2.22.patch
@@ -0,0 +1,23 @@
+Index: kanatest-0.4.8/Makefile.am
+===================================================================
+--- kanatest-0.4.8.orig/Makefile.am
++++ kanatest-0.4.8/Makefile.am
+@@ -1,5 +1,5 @@
+ SUBDIRS = src po data
+-ACLOCAL_AMFLAGS = -I m4 -Wall
++ACLOCAL_AMFLAGS = -Wall
+
+ EXTRA_DIST = README AUTHORS TRANSLATORS COPYING ChangeLog
+
+Index: kanatest-0.4.8/src/Makefile.am
+===================================================================
+--- kanatest-0.4.8.orig/src/Makefile.am
++++ kanatest-0.4.8/src/Makefile.am
+@@ -1,6 +1,5 @@
+ REVISION := $(shell if test -e .svn; then echo -DREV=\"`LC_ALL=C svn info | sed -n '/^Rev/p'| sed -e 's/^Revision:\ //'`\"; fi;)
+-AM_CPPFLAGS = -Wall -DLOCALEDIR=\"$(datadir)/locale\" $(REVISION) \
+- -DGDK_PIXBUF_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED
++AM_CPPFLAGS = -Wall -DLOCALEDIR=\"$(datadir)/locale\" $(REVISION)
+ bin_PROGRAMS = kanatest
+ kanatest_SOURCES = about.c about.h \
+ chart.c chart.h \
diff --git a/app-misc/kanatest/files/kanatest-0.4.8-autoconf.patch b/app-misc/kanatest/files/kanatest-0.4.8-autoconf.patch
new file mode 100644
index 000000000000..e92747646a6c
--- /dev/null
+++ b/app-misc/kanatest/files/kanatest-0.4.8-autoconf.patch
@@ -0,0 +1,13 @@
+diff --git a/configure.ac b/configure.ac
+index eca7a05..b5ac45c 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -3,7 +3,7 @@
+
+ AC_PREREQ(2.59)
+ AC_INIT([Kanatest], [0.4.8], [pasp@users.sf.net])
+-AM_INIT_AUTOMAKE([-Wall -Werror foreign])
++AM_INIT_AUTOMAKE([-Wall -Wno-portability -Werror foreign])
+ AC_CONFIG_SRCDIR([src/about.c])
+ AC_CONFIG_HEADER([config.h])
+
diff --git a/app-misc/kanatest/files/kanatest-0.4.8-cflags.patch b/app-misc/kanatest/files/kanatest-0.4.8-cflags.patch
new file mode 100644
index 000000000000..1f3835803e8b
--- /dev/null
+++ b/app-misc/kanatest/files/kanatest-0.4.8-cflags.patch
@@ -0,0 +1,13 @@
+diff --git a/configure.ac b/configure.ac
+index b5ac45c..c2c6d18 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -38,7 +38,7 @@ AC_CHECK_LIB(xml2,
+ [],
+ [AC_MSG_ERROR(You do not appear to have libxml2 installed.)])
+
+-CFLAGS="$BUILD_CFLAGS -Wall $PLATFORM_CFLAGS -D_GNU_SOURCE"
++CFLAGS="$CFLAGS $BUILD_CFLAGS -Wall $PLATFORM_CFLAGS -D_GNU_SOURCE"
+ CXXFLAGS="$CFLAGS"
+ CPPFLAGS="$gtk_CFLAGS $xml_CFLAGS"
+ LIBS="$gtk_LIBS $xml_LIBS"